Home | News | Documentation | Download

Run ROOT 6.19.02 on Windows 10

Hi,

I tried to run ROOT 6.19.02 on Windows 10 from Visual Studio 2019 Developer Command Prompt but I got the following message:

input_line_1:1:10: fatal error: ‘new’ file not found
#include
^~~~~
Assertion failed: OldBuilder->DeferredDeclsToEmit.empty() && “Should have emitted all decls deferred to emit.”, file C:\build\ws\BUILDTYPE\Release\LABEL\windows10\V\6-20\root\interpreter\llvm\src\tools\clang\lib\CodeGen\ModuleBuilder.cpp, line 139

After this, the ROOT does not start. Could you help me to solve this problem?

This is most probably due to different versions of Visual Studio (and/or Windows 10 SDK) between the one installed on your system and the one used to build ROOT. While we will work to get rid of this limitation, I think the only solution would be to build ROOT from source

The problem was the different versions of Windows 10 SDK. Now it works. Thank you very much for your help!

1 Like

Hi! What version of SDK should I install on Windows 10 to work with root_v6.20.02.win32.vc16? Thank you!

Windows SDK version 10.0.18362.0

Try to install Windows SDK version 10.0.18362.0, but it setup 18362.1 instead and with it ROOT cannot work properly - i still get a bunch of errors!

How did you get it? The latest one is 10.0.18362.0


Just run vs install utility. See uploaded pictures.

But then:

And if you try to download Windows SDK version 10.0.18362.0 from MS site, you get new version! 1 not 0!

OK, so you will have to build ROOT from source

I installed Windows SDK version 10.0.18362.1 and ROOT 6.20.02 works without any problem.

No luck! How can i compile ROOT from sources? Is any tutorial?

There are several topics you can find on this forum, for example:


You need CMake (latest version), and then you can:

  • Unzip the source tar file in a directory not containing any space
  • Open a x86 Native Tools Command Prompt for VS 2019 !!!And NOT a x64 one!!!
  • Create a build directory of your choice and cd into it
  • Then configure ROOT with: cmake -G "Visual Studio 16 2019" -A Win32 -Thost=x64 -DCMAKE_VERBOSE_MAKEFILE=ON -DCMAKE_CXX_STANDARD=14 [path to source]
  • Then, if there was no error, build ROOT: cmake --build . --config Debug

Note that if you need more options, you can open a cmake-gui where you can select the different options before building ROOT (be aware that all of them are not supported on Windows)

Thanks! Its work! Its took me something about 7-8 hours to compile ROOT on Xeon X5460 with 4 Gb RAM/

1 Like