OS/ROOT issue

Dear Experts,
I am running a same Fitter script in two different OS. Here are the information about the OS.
OS 1 :
Distributor ID:Ubuntu
Description:Ubuntu 22.04.2 LTS
ROOT 6.26/10

OS 2 :
LSB Version:core-4.1-amd64:core-4.1-noarch
Distributor ID:CentOS
Description:CentOS Linux release 7.9.2009 (Core)
ROOT 6.22/06

“OS 1” is my local area, where “OS 2” is the lxplus area. I observed the same Fitter code runs well in “OS 1” but it fails in “OS 2”. But most of the things I need to do in lxplus area which is “OS 2”. Could you please let me know the reason behind it and what can be done to fix the issue at lxplus?

Best regards,

Dear Experts,
Could you please help with it?


Can you tell more? how does it fail?

The Fitter didn’t converge. Here I am attaching two plots for your reference, where the same Fitter is converge and failed in another case.

Hi! It’s hard to tell what the problem is just from this plot.

Have you tried the new ROOT 6.28.04? Maybe the problem is fixed there?

If it’s still not fixed, maybe you can link/attach your scripts so we can reproduce the problem?


Dear @jonas ,
Yes the fit worked in ROOT 6.26.10 which is my local area. But when I run the script on lxplus(CentOS 7) by sourcing ROOT 6.26.04 (source /cvmfs/sft.cern.ch/lcg/views/LCG_102/x86_64-centos7-gcc11-opt/setup.sh), it shows the " *** Break *** segmentation violation" error.
I have attached below the complete error information and script (workspaces and data file) which is running well in my local area.
Kindly have a look and please let me know how I can fix this at lxplus area.


ERROR.txt (7.7 KB)

Bmass_Fit_Bin3.C (7.6 KB)
CMC_2016_Bin3_062023_1.root (22.5 KB)
wspace_2016_bin1C.root (53.6 KB)
wspace_updated_bkgM_KStarFitter_2016_bin1C.root (11.6 KB)
wspace_updated_massSB_2016_bin1C.root (8.9 KB)
wspace_updated_sig2DFitter_2016_bin1C.root (14.2 KB)
wspace_updated_sigMDCBFitter_2016_bin1C.root (11.6 KB)

The solution is already in your last answer :slight_smile: So if ROOT 6.26.10 works in your local area, why not just use ROOT 6.26.10 on lxplus as well? That works for me with your files!

As described here on the release page, you just need to:

source /cvmfs/sft.cern.ch/lcg/app/releases/ROOT/6.26.10/x86_64-centos8-gcc85-opt

Not that you need to ssh to lxplus8 now, because the newer ROOT builds on cvmfs don’t support CentOS 7.

But if you replace LCG_102 with LCG_103 in your source path, then you can also use CentOS 7 again. You have the even newer ROOT 6.28.00 as part of LCG_103, which should work as well.

In any case, what you encountered was either a bug that got fixed in ROOT 6.26.10, or maybe the input files were produced with ROOT 6.28.10 or newer and there were some compatibility problems of reading them with an older RooFit version.

Dear @jonas ,
Thanks a lot. Indeed it worked in lxplus8 with ROOT 6.26.10.

Best regards,

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.