Opening TBrowser causes XQuartz to unexpectedly quit

So I used to be able to use root without any problems. Now whenever I open TBrowser the entire XQuartz application quits. Here is what I do:

ssh -Y
lsetup root

Then I get an error:

LoadROOTSplashscreenPixmap, failed to load a splashscreen image
LoadROOTSplashscreenPixmap, failed to load a splashscreen image
PopupLogo, failed to create a background pixmap

in root I just try to open TBrowser with

root [0] TBrowser b

it takes a minute to open the Browser window but as soon as it loads the entire XQuartz application quits. The same thing happens if I try to just draw a histogram with


I have tried updating root on my local computer. I now have ROOT 6.10/04 .
I have not changed anything else since. And everything was working fine a week ago.
The version of XQuartz I have is 2.7.11.

Any help would be appreciated.



The message:

LoadROOTSplashscreenPixmap, failed to load a splashscreen image

Shows that the X11 connection with your Mac did not work. Any graphics won’t display.
It is not connected to TBrowser. I guess you will have the same problem opening a TPad or even starting any X11 application like xterm or clock can you try ?

This is not related à you are running ROOT on lxplus.

Yes I have the same problem when opening TPad or TCanvas in root. However xterm and xclock work fine.

This is weird … Are you at CERN ?

No I am not at CERN.

I can run root fine on my local computer but if I try to run it on lxplus or on our ATLAS tier 3 site I get this error.

I thought it might have something to do with the $DISPLAY variable but it looks ok on both logins:

[sferguso@lxplus044 ~]$ echo $DISPLAY

: swf140030@g20 ~; echo $DISPLAY

are there any other variables I can check? I tried the suggestions on for ssh forwarding debugging and everything looks fine except possibly:
"[6] remote $ grep X11 /etc/ssh/sshd_config ~/.ssh/*
X11Forwarding yes
X11DisplayOffset 10" (this is what the website above says it should look like)

for which I get:

[sferguso@lxplus044 ~]$ grep X11 /etc/ssh/sshd_config ~/.ssh/*
grep: /etc/ssh/sshd_config: Permission denied

and the same thing on our tier 3 site.

Update: I know it is a problem with my computer. I have had another graduate student log onto lxplus from my terminal and he had the same problems as me when trying to use root.

I have also used my advisor’s computer (which also uses XQuartz on a mac) to logon to my lxplus account and my account on our tier 3 site. When using his computer, I do not have these problems.

This tells me that there is not a problem with my environment on lxplus or my tier 3 account.

I uninstalled and reinstalled XQuartz. I still have the same problem as before.

You said that you are able to display xterm or clock from lxplus to your Mac … so XQuartz on Mac is correct. I do not understand why only ROOT has problem. Can you try to start ROOT with the option - n to not execute the rootlogon.C file . It might be that you have something in it causing the problem. Which ROOT version are you using ?

I still have the same issues when I do this.

I’ve mainly been testing it with version 6.10/04 but I have tried it with other versions including 5.34/10, 6.00/00, and 6.04/18 as well as some others. I get the same error at the startup with all the 6.xx/xx and get this error message for the 5.xx/xx
rootx xpm error: XpmColorFailed

For the version 6.00/00 I get the original error message in an above post along with an error about cling:

[sferguso@lxplus056 ~]$ root
LoadROOTSplashscreenPixmap, failed to load a splashscreen image
LoadROOTSplashscreenPixmap, failed to load a splashscreen image
PopupLogo, failed to create a background pixmap
Warning in cling::CIFactory::createCI():
C++ ABI mismatch, compiled with __GLIBCXX__ v20130531 running with v20141219

But I do not get the last two lines here when I use other versions.
I get the same error message if i run with root -n.

After the splash screen error which error do you get when you try to open a TPad ?
I must admit I am really puzzled with your issue and do not really know what it could be,

I do not get an error message when I open TPad. It causes XQuartz to completely quit. Same as when I open TBrowser or TCanvas.

Thanks for trying to help!

That’s really super weird … XQuartz and ROOT are not running on the same machine … I have never seen the XQuartz server falling down because of a ROOT session running on a remote machine. I do not see how I can help from here without trying on your machine. May be some local expert can try to help you ?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.