Opening ROOT display(TBrowser) causes XQuartz to unexpectedly quit

Dear ROOT community

I am working on an ssh connection to (lxplus) and I have XQuartz installed on my macbook. It used to work without any error but now it crashes whenever I launch TBrowser or TCanvas or Draw option while the xterm for instance works perfectly from the same machine on lxplus.

In this screenshot you can see the ROOT version and the errors I get.

I went through this issue Ticket and it describes exactly the same problem I am encountering but unfortunately there was no solution proposed.

I would really appreciate it if you could help me to sort out this issue,

Thank you,

I just tried. (ssh -X -Y to lxplus) it works for me (same ROOT version)

Thanks for your reply Olivier. I forgot to mention that I always connect using -XY so still not a solution. There must be something else that should be done but I still don’t get it…

May be the lxplus node you landed on has an issue ? just to be complete my Mac is MacOS 10.15.3

I have tried different lxplus nodes but the issue persists. my Mac is macOS 10.14.6. I started having this issue just few days ago even there was no updates or any other change.

I just tried again. It is fine for me … see the attached screen dump.

On your “lxplus” node, try to execute:

root-config --prefix
echo ${ROOTSYS}
root-config --bindir
echo ${PATH}
root-config --libdir
root-config --etcdir # make sure that this directory exists

Also, try to run e.g. “xterm” and / or “emacs” and see if you get its window displayed.

Thank you Wile for your suggestion. I have executed the command lines and still the same issue. TBrowser and all ROOT related display unexpectedly quits and for xterm, it works! . Regarding emacs or gedit when I run it it doesn’t quit but it appears all in black.