Forum problems

could someone, please, fix the following issues:

  1. a lot of attachment “file-types” are not properly recognized and then they are refused (for example “.cc”)

  2. a lot of “URLs” are not properly recognized and then they are improperly displayed - even links to ROOT pages get broken - for example: … raphErrors%8

  1. posts without “text” are not allowed - from time to time I just want to post an “attachment” without any explanations

  2. I cannot delete my posts nor topics / threads that I started - from time to time I would like to “clean” something

Hi Pepe,

  1. I’ve added .cc. Let me know if you need other extensions.

  2. I’ve filed an bug report with the phpBB developers.

  3. Cannot change. Just add a single line as courtesy.

  4. Only moderators can delete.

Cheers, Fons.

I’m just going through my old posts …

  1. could you also, please, add “.f”, “.F” and another fortran related extensions to the list
  2. also, “.h”, “.hxx”, “.cxx” were not working (but are probably fixed by now)

I understand that in general “only moderators can delete”, but maybe there’s an option which allows ordinary users to delete their own posts.

There’s another point that came to my mind … from time to time I try to search the forum for a specific word but I get “words in your search query were ignored because they are too common words” … or a similar stupid message …
Could you, please, block this feature (and similar / related) … if I get a long list of “hits”, that’s my problem … maybe that’s what I wanted.
Also lowering the minimum required number of characters in the word to search from 3 to 2 would be nice.
Finally, the search machine does not allow certain characters, like “" for example (it changes them into a “space”) - if possible, please, switch this off - if I write a word which has a "” in it, it should be able to find it.

Well, that’s precisely what I was doing (many times here), but then people complain that they do not understand that single simple short “courtesy” line at all :exclamation: :wink: :mrgreen:

Hi Pepe,

.f, .F and .hxx are now also added (the others mentioned were already there).

It seems there is no user delete permission, it seems.

I’ve also changed the search word length from 3 to 2 and disabled the common word algorithm.

Cheers, Fons.

Just got another … “The extension hh is not allowed.”

How about underscores? Can you make them “ordinary” characters?
Just try to search for “CINT” …

Ok you also got .hh :slight_smile: The __ I cannt change so easily.

Would it be possible to make “makefile” and “Makefile” names recognized as valid attachments?

More difficult. Just rename the files to Makefile.txt.

Cheers, Fons.

Could you, please, remove the line 130:
width: 850px;
from the file:
(this will make the forum’s “graphical interface” to use the “current” window width, chosen by the user).
Thanks in advance.

No beause this way it is consistent with the Drupal site width. I’ll see if it can be a user option.

Cheers, Fons.

Well, it seems you can also remove line 42:
width : 850px;
from the file:
and then everything is consistent.
There is also the line:
min-width: 750px;
in the file:
but that doesn’t make that much harm (well, it may start to make problems once the 850px requirement is lifted).

Well, I’d like to return to the “width” problem …
It happens to me that I see just the “left part” of pictures on the screen …
A new case of this problem is here: [url]Ranged fit give poor results
I don’t know how it looks like on your screens, but on mine, the pictures are “cut” and there’s no way to see them whole (the most right part of the picture, that I am able to see on my screen at all, is attached below).

I plan to install this mod: … 3b4bdb833e

which should correctly handle image resizing for these large files. Would that help you?

Cheers, Fons.

Am I the only one who has this problem?
If yes, maybe I should change some settings in my Firefox?
I have no practice with “ReIMG” so I can’t tell in advance if it helps or not, sorry.
From my point of view, the best solution would be removing any “hardcoded” widths.

Hi Pepe,

have a look at the page with the big pictures. You should like what you see (at least I like it).

Cheers, Fons.

It mostly works. =D>
There are possibly two problems.

  1. I’m not sure if this new feature should automatically work for all old posts - if yes, then it doesn’t work for the picture in this post (I still cannot see the right part of this picture and there’s no embedded “+” button to “zoom in” at all): [url]TH2 Drawn with "colz" option - colors and range
  2. looking at the “original problem case”, I can see the whole picture now. If I click the embedded “+” button, I get a “zoomed in” version (which is also fine). That new picture contains again two buttons (top-left): “-” for “zoom out” and “+” for “real dimensions” - but that next “full zoom” / “real dimensions” button works badly.
    I have just realized that the problem 2 depends on the actual size of Firefox’es window - when I resize the window, the “full zoom” picture’s size “jumps” - sometimes it takes the majority of the available window and sometimes it’s very flat (even flatter than what you see in the picture above), but it always takes the full available width of the Firefox’es window.

It should work for old posts but it is not enabled for image attachments (and would not work retroactively anyway) which is the first image in your example. I could enable it for future image attachments.

Cheers, Fons.

Could you, please, add “.ps”, “.eps” and “.tex” (and maybe also “.js”) as valid extensions of attachments.

ok, done.

Cheers, Fons.

Sorry, I forgot about the “.dat” extension (already a couple of people were renaming “.dat” into “.C” in order to attach them).