Can't display TGraphErrors plots correctly via Adobe Reader

Dear experts,

I’m trying to make a plot using TGraphErrors. Please see the attachment. It looks the output plot displays correctly, in preview in Linux and Mac. But there is always problem when displaying via Adobe Reader under Windows7. I don’t know if this is related with the Reader or there is some potential problem in my code…Also if I save it to png file, you will see a short dash line on the top left of the canvas, what’s the reason for this? Thanks.
pt_leadinglepton_mumu.C (61.2 KB)

I will look. (Usually it is the opposite is: Adobe is correct and preview wrong)

What is the problem exactly ?

I do not see it.

I attach the screenshot of displaying via Adobe Reader under Windows7.

You see the TGraphErrors are not shown correctly…

But I do see it in my first attachment(pt_leadinglepton_mumu.png)…

By the way, I attach my source code to draw such plots (although you can’t repeat because you don’t have input samples).
Thanks.plot_HSS.cxx (52.5 KB)

Here is the plot I get with adobe on mac.

May your adobe version has problems rendering 3004. try 3254 instead

It still doesn’t work for 3254…

That’s exactly the weird thing, the plots work fine everywhere except in adobe on Windows. I tried to update to the latest version of adobe, but didn’t work. (see same problem if using other’s windows computer)
And the other thing is about the ‘dashed line’, it only occurs in png file (on Mac and Windows). I thought this might give some hints.
I really don’t know what’s going wrong there…

Can you try this macro: pt_leadinglepton_mumu.C (61.1 KB)

For the dash line I can not reproduce it with the macro you sent. On windows you run 5.14 I guess. It might be that something was fixed in 6.xx

I just tried the 1st macro you sent on Mac with 5.14 … no dash line.

Ah, it works for the macro you sent. May I ask why? Thanks.
I see the only change is 3004->3254, but when I change it directly in .cxx, it doesn’t work.

The 1st macro you sent (the one i modified ) is one produced by Print method.
I cannot run the 2nd one you sent… which is the real one …
may be you changed the fill style in the wrong place ? may be you forgot some places ?

I do modified the fill style. There are only two places which I need to modify…

Ok … so To help further I would need to run the original macro

I put all the necessary samples here: /afs/
You only need copy this directory and just run: root -l plot_HSS.cxx
Thanks in advance!

I am missing some file:

$ root -l plot_HSS.cxx
root [0] 
Processing plot_HSS.cxx...
In file included from input_line_10:1:
/Users/couet/roottest/mason/plot_HSS.cxx:21:10: fatal error: 'atlasstyle-00-03-05/AtlasStyle.C' file not found
#include "atlasstyle-00-03-05/AtlasStyle.C"

Did you copy the whole directory? The sub-directory atlasstyle-00-03-05/ should be in ForCouet/ .

Got it now. scp missed it at first . Thanks

Your macro generates 3 pdf file (mumu). Only the 3rd one has the fill style 3254. an it seems you forgot to change some 3004:

imaccouet:mason couet$ grep 3254 *.cxx
plot_HSS.cxx:      gr_stack_mumu->SetFillStyle(3254);
plot_HSS.cxx:      gr_ratio_bkg_mumu->SetFillStyle(3254);
imaccouet:mason couet$ grep 3004 *.cxx
plot_HSS.cxx:      gr_stack_ee->SetFillStyle(3004);
plot_HSS.cxx:      gr_ratio_bkg_ee->SetFillStyle(3004);
plot_HSS.cxx:      gr_stack_emu->SetFillStyle(3004);
plot_HSS.cxx:      gr_ratio_bkg_emu->SetFillStyle(3004);
imaccouet:mason couet$ 

Yes, that macro makes three pdf files in parallel. All of them have the adobe problem. I only tested for mumu part, but it didn’t work.

I get the correct display with Adobe but It gives me an error message on Mac.
I can investigate but it will take time… your macro is quite long…

Thank you very much, but I should have said that maybe you could just investigate the code after line 585, where drawing starts. Please take your time.