Yosemite, ROOT 6.02 and Xcode atos -d option


I installed Root 6.00.02 on OS Yosemite and it seemed to be okay when I opened old root files from Geant4. However I encountered problem when I made new runs under OS Yosemite environment. When I tried to open the histograms I got error messages as below. It looks like Xcode 6.1 does not have “-d” option while ROOT tried “-d” option. I can still open my old root histograms came from OS 10.9, no problem at all. Is that because of the histogram file format generated from Geant4 or ROOT 6.00.02/Yosemite problem? I sent the new data to my colleague, he has OS X 10.9, ROOT 6.00.02. He can open it, no problem.



$ root

| Welcome to ROOT 6.02/00 http://root.cern.ch |
| © 1995-2014, The ROOT Team |
| Built for macosx64 |
| From tag v6-02-00, 30 September 2014 |

Try ‘.help’, ‘.demo’, ‘.license’, ‘.credits’, ‘.quit’/’.q’

root [0] new TBrowser
(class TBrowser *) 0x7f97b24979f0
root [1] (class TFile *) 0x7f97b6a73250
*** Break *** segmentation violation
Generating stack trace…
[invalid usage]: unrecognized option '-d’
Usage: atos [-p pid] [-o executable] [-f file] [-s slide | -l loadAddress] [-arch architecture] [-printHeader] [address …]
0x000000010a584bea in _ZN20TStreamerInfoActions17GenericReadActionER7TBufferPvPKNS_14TConfigurationE + 0x4a from /Users/root/lib/libRIO.so
[invalid usage]: unrecognized option '-d’
Usage: atos [-p pid] [-o executable] [-f file] [-s slide | -l loadAddress] [-arch architecture] [-printHeader] [address …]
0x000000010a522bcd in _ZN11TBufferFile13ApplySequenceERKN20TStreamerInfoActions15TActionSequenceEPv + 0x3d from /Users/root/lib/libRIO.so[/code]

I downgraded ROOT to v5.34/23 and it read all *.root files normally.

Dear experts,

I’m having the same issue (Yosemite, ROOT 6.02/02, Xcode 6.1.1).
Looking at core/unix/TUnixSystem.cxx, it looks as if the -d option should only be used under this condition:

#if defined(MAC_OS_X_VERSION_10_9)

but isn’t it strange that this is executed even though (in config/Makefile.config) MACOSXVERS=10.10 ?



Thanks, that stack trace error is a bug, I have created sft.its.cern.ch/jira/browse/ROOT-7002 for that.

For the file read triggering a crash: which file are you opening, which object are you reading? Can we have the file to understand what’s triggering that?

Cheers, Axel.


Attached is the ROOT file. I can use ROOT 5.34/23 open it without any disruption. ROOT 6.02/00 cannot read any of the histograms. The error message pops up.


FAN01.root (54.2 KB)


root.cern.ch/drupal/content/how … s-its-name

Thanks, object’s name seems to be the problem. ROOT 6.02 works fine to open other objects with proper names. Problem solved. Thanks again.