Why i am getting when i run any macro file?

this is the file i am trying to run.
roottut1.c (1.1 KB)
any help will be appreciated .

It works for me:

% root roottut1.c 
  | Welcome to ROOT 6.25/01                        https://root.cern |
  | (c) 1995-2021, The ROOT Team; conception: R. Brun, F. Rademakers |
  | Built for macosx64 on May 04 2021, 10:25:01                      |
  | From heads/master@v6-25-01-760-g30ab704cbe                       |
  | With Apple clang version 12.0.5 (clang-1205.0.22.9)              |
  | Try '.help', '.demo', '.license', '.credits', '.quit'/'.q'       |

root [0] 
Processing roottut1.c...
root [1] 

yes, earlier it was working for me also, but now i am getting this, i don’t understand why it is happening.
it is due to some snap or something like that.
can you please sort out this problem ?

First you typed the root command in a place where you macro does not exists, then you type the wrong name. Can you go in the directory where the macros sits and type:

% root roottut1.c 

same result

Which root version are you using ? On which machine ?

Hello, author of the snap here. I’ve just run this on my machine with the same revision as you and don’t experience the same problem.

The simplest thing I’d recommend is simply rebooting the machine, it’s always a good idea for when things just suddenly act up like this, especially given how complex todays systems are.

I’d appreciate if you could run the command snap changes in the terminal and post the output, it should show the latest updates to any snaps you have on your system. For ROOT specifically, there’s only been one update in the last month and it was to simply update a bundled dependency that shouldn’t be causing this problem. What I would be looking for is any changes to either “core” “core20” “snapd” and “root-framework”.

The stack trace contains some explicit references to fonts. Fonts are difficult to work with in snaps and cause some weird errors, however they shouldn’t be responsible for just randomly crippling its ability to work. If you could run rm ~/snap/root-framework/current/.last_revision after the reboot from before and see if it makes any difference, that’d be very helpful too.

In the scenario ROOT was updated and the previous revision worked better for you (or just to see if it does), you can actually also roll back the entire package with sudo snap revert root-framework, however I wouldn’t assume this would help in this instance.


  | Welcome to ROOT 6.24/00                        https://root.cern |
  | (c) 1995-2021, The ROOT Team; conception: R. Brun, F. Rademakers |
  | Built for linuxx8664gcc on May 26 2021, 07:38:00                 |
  | From tags/v6-24-00@v6-24-00                                      |
  | With                                                             |
  | Try '.help', '.demo', '.license', '.credits', '.quit'/'.q'       |

and i am using Ubuntu 20.04

also i rebooted the system give above command and getting this.

After doing the revert, you can try running your macro again to see if it works. If it doesn’t, use the rm ~/snap/root-framework/current/.last_revision command again, since after having reverted it’ll have reset the effects.

I’d also try regenerating the system font caches, like so

sudo rm /var/cache/fontconfig/*
rm ~/.cache/fontconfig/*
fc-cache -r

And trying to run your macro again after.

If it still doesn’t work, I would expect the other ROOT installation methods to be functional but if you’d like to keep trying to diagnose the snap specifically I can keep going :slight_smile:

one question also @James-Carroll @couet
when i install root , then version was 6.20.06 but now when i type root on terminal then i see root version is 6.24/00
why it is so, i didn’t update root version but it gets updated, can it be the problem ?

6.24 is the latest version. It seems you installed it.

no, it does not work.

should i run this command at home terminal or inside the root folder where i have installed root, can you please tell.

The snap automatically updates to the latest stable release. If you’d like to stick on the 6.22 releases, you can run sudo snap refresh root-framework --channel v6.22 it will then only ever fetch the latest version of the v6.22.x releases, but I would not assume that the problem here is related to the version of ROOT. If wanted to keep the absolute same revision forever, you’d need to install it via a sideloading mechanism so it never attempts to contact the store, but I wouldn’t recommend this for the majority of users.

It can be anywhere, as long as it’s the Bash prompt and not the ROOT prompt.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.