Very slow histogram drawing in TBrowser


I have a problem with viewing histograms in TBrowser.

I’ve freshly installed new system on my workstation (Debian 8 ) and also istalled lastest ROOT 5 (5.34/36). I tried to view some histograms (TH1, only a few bins) in TBrowser, but it turns out that it takes 10-20 seconds until histogram is drawn on canvas. I din’t have such problem with the very same TFile and TH1 in my previous system installation (Ubuntu and ROOT 5.34/34). The problem is general and applies to all ROOT files and histograms I tried to draw in browser.

Any idea what may be the cause? Something with x-server?

Best regards,


Is it only in the TBrowser?
Is drawing in a simple canvas OK?

Cheers, Bertrand.

Can you provide the macro with this “slow drawing” ?

[quote]Is it only in the TBrowser?
Is drawing in a simple canvas OK?[/quote]

It happens only with TBrowser.

Once I close the “default” canvas which is embedded in browser, and then double-click on some histogram in the left panel, new window (external canvas) is immediately displayed and histogram is drawn without any delay. However, when I then double-click on some other histogram I still have to wait >10 seconds for histogram to be drawn in external canvas (which I haven’t closed).

To me it looks like problem with canvas updating/refreshing.

I’m not sure if TBrowser issue can be reproduced with macro, will try.


I noticed something important (in my opinion). To get histogram drawn in canvas embedded in TBrowser I need to left-click on the canvas external area (on TCanvas object). I think that once I click on the canvas a TPad::Update() is invoked, am I right? Any idea why it is not invoked by default?


Hi Rafal,

Sorry, we cannot reproduce the problem, and it looks like a X11 issue. Could you try with ROOT 5.34/34 on that machine, to make sure it is the machine causing the issue (and not the ROOT version)?

Cheers, Bertrand.

I tried a few ROOT versions available through CVMFS, and unfortunately for all the same effect appears. I will try to look for solution related to X11. Thanks.

Hi All,

I would like to report that I found the solution to my problem. It is quite straightfoward.

In the system.rootrc file, I changed

X11.Sync: noto

The problem’s gone.