True white in root

What is the command so that your canvas the histogram is on is TRULY white, i.e. suitable for putting in a document? I put some of my histograms into my thesis only to discover that they print kind of grey, because the canvas background isn’t REALLY “white white”.

What setting should I use so no color at all is applied the backgrounds when I try to print histograms? Thank you!

Have you tried:



Yes I did try that. It looks white on the screen in ROOT but when I save it as a .eps file and compile it using LaTex, it comes out that same shade of grey. You can see on the screen that it isn’t REALLY white, and then when you print it, you get a grey-ish background.


Setting canvas->SetFillColor(0); should help.

Cheers, Ilka

Hi, setting canvas->SetFillColor(0) did help. The only “proble area” which remains is the box around the histogram title. On the screen it looks white. But when I print it, the box which contains the histogram title has a gray shading to it. I am having difficulty finding a command to turn that off-also, if I could turn the “box” which surrounds the title off completely that might help.

you can also add: