TNetXNGFile::Open fails with double slash (//) in path (2)

I just observed the exact same behavior as described here. Removing the double slash solves the issue.
The error observed is as follows:

Error in <TNetXNGFile::Open>: [ERROR] Server responded with an error: [3011] Unable to open file /eos/<path>; No such file or directory

ROOT Version: 6.20/02
Platform: SLC7
Compiler: GCC 8.3.0

So the problem is solved ?

It is indeed solved, but this seems insufficient.
My point was that the behavior is unexpected, and error-prone. I myself had to spend a long time trying to figuring out what the issue was. Even if ones does not want to automatically convert the double slash into a single slash in some scenarios, I would expect to receive a warning, at least. The behavior goes against what any Linux user would expect, and it even modifies the string in an unexpected way (it trims the last characters).

Hi @bfontana ,
please open a bug report at Issues · root-project/root · GitHub, it might not be high-priority but it might be something that we want to look at.


Done: TNetXNGFile::Open fails with double slash (//) in path · Issue #7159 · root-project/root · GitHub

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.