TDataFrame segfault on error reading file [2]

Connected to: TDataFrame segfault on error reading file

I’ve now upgraded to ROOT 6.14, and I still get segfaults.

ROOT Version: 6.14/01
Platform: LCG dev4
Compiler: GCC 7.3


what is the code you are running? This is something unexpected and if reproducible to be fixed asap.


If you have access to ATLAS code:

The code is at
The file it segfaults on is user.bstanisl:user.bstanisl.13910762._000304.MiniNTuple.root


apologies, I missed the reply :frowning:
I think I don’t have access: can the file be shared with cernbox together with 20 lines of code reproducing the crash?


Huh, running on just that file seems to be working (it hasn’t finished yet).

Nevertheless, with a missing file (/ incorrect filename):

Error in <TExMap::Add>: key 140639610989984 is not unique
Error in <TFile::TFile>: file /data/atlas/atlasdata2/Exotics/HH4b/Ntuples/Rel21-Group-NTuples-2018-05/user.bstanisl.HH4B.2018-04-30T0908Z.data16-rel21_MiniNTuple.root/user.bstanisl:user.bstanisl.13910762._000304.MiniNTuple.root does not exist
Error in <TFile::TFile>: file /data/atlas/atlasdata2/Exotics/HH4b/Ntuples/Rel21-Group-NTuples-2018-05/user.bstanisl.HH4B.2018-04-30T0908Z.data16-rel21_MiniNTuple.root/user.bstanisl:user.bstanisl.13910762._000304.MiniNTuple.root does not exist
terminate called after throwing an instance of 'std::runtime_error'
  what():  Unknown columns: runNumber,lumiBlock

Though the TExMap error also appears when the file name is correct, and doesn’t cause a crash.


I think I need that file in order to debug: are you sure it’s not corrupt? It looks like it.



But as I said, when I run on just that file, it doesn’t crash, though it does print the TExMap error.
The output above was when I got the filename wrong (by leaving the user.bstanisl: in at the beginning). Evidently, ROOT still crashes if the file does not exist / is empty.

Just FYI, here are some of the errors:

Error in <TBranchElement::GetBasket>: File: /data/atlas/atlasdata2/Exotics/HH4b/Ntuples/Rel21-Group-NTuples-2018-05/user.bstanisl.HH4B.2018-04-30T0908Z.data16-rel21_MiniNTuple.root/user.bstanisl.13910762._000084.MiniNTuple.root at byte:389515562, branch:resolvedJets_phi, entry:314988, badread=1, nerrors=5, basketnumber=397
Error in <TBranchElement::GetBasket>: File: /data/atlas/atlasdata2/Exotics/HH4b/Ntuples/Rel21-Group-NTuples-2018-05/user.bstanisl.HH4B.2018-04-30T0908Z.data16-rel21_MiniNTuple.root/user.bstanisl.13910762._000084.MiniNTuple.root at byte:389477808, branch:resolvedJets_E, entry:314988, badread=1, nerrors=6, basketnumber=397

 *** Break *** segmentation violation
Error in <TBranchElement::GetBasket>: File: /data/atlas/atlasdata2/Exotics/HH4b/Ntuples/Rel21-Group-NTuples-2018-05/user.bstanisl.HH4B.2018-04-30T0908Z.data16-rel21_MiniNTuple.root/user.bstanisl.13910762._000180.MiniNTuple.root at byte:123347244, branch:passedTriggers, entry:99930, badread=1, nerrors=7, basketnumber=1478

 *** Break *** segmentation violation
Error in <TBranchElement::GetBasket>: File: /data/atlas/atlasdata2/Exotics/HH4b/Ntuples/Rel21-Group-NTuples-2018-05/user.bstanisl.HH4B.2018-04-30T0908Z.data16-rel21_MiniNTuple.root/user.bstanisl.13910762._000609.MiniNTuple.root at byte:83520267, branch:passedTriggers, entry:67808, badread=1, nerrors=8, basketnumber=1019

 *** Break *** segmentation violation

I’m beginning to think it isn’t actually caused by corrupt files, but by some sort of issue on the cluster.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.