TBrowser on lxplus runs slowly, perhaps due to font?

ROOT Version: 6.16
Platform: Ubuntu 18.04


I have recently had to do a factory reset on my laptop, and have run into some problems when trying to use ROOT on lxplus. My laptop runs Ubuntu 18.04, and in the past I had this problem, but managed to fix it although i now don’t remember how.

When I run a TBrowser on lxplus, it takes a few minutes to open, where before it would open much faster, and in general there is a sort of input lag present while i navigate the TBrowser. Once I have opened my decay tree in my root file, it works faster, but still slowly overall. When I try this from a windows PC on the same wifi, this problem is non-existent, the TBrowser opens fast and is responsive, so I do not think it is caused by a bad wifi connection.

I seem to remember that the last time i ran into this problem, it was due to the font of the tbrowser. It seemed as though the TBrowser was trying to display in the incorrect font (or a font that my laptop did not have possibly?) and this was causing the lag, as it had to look in other places to find this font. But ultimately, I am unsure what may be causing this and am not sure how to fix it, so any advice would be much appreciated, Thanks.

Hard to tell - and our GUI expert is on leave until the end of the month. I’ve asked @couet for help; maybe he has an idea, or an idea how to debug this.

Do the system logs show anything? Your ~/.xsession-... whatever it’s called?

Thanks for the quick reply. I don’t see a file like this anywhere in my directory, i’m unsure if it maybe has a different name, but nothing sticks out to me. Sorry for not being more helpful.

May be this can help:

In particular the The Xft stuff at the end.
If not @bellenot will know when he will be back.

I was referring to a file called .xsession-errors in your $HOME directory. But yes, @couet probably has the solution for you :slight_smile:

I have been trying the solutions posted in this thread before, i.e. making a .rootrc file as well as looking at the font root is using. Adding a .rootrc file had no effect, and the fonts that are listed are the same as in the thread, but I can’t change this as i dont have write permissions for the system.rootrc file since its lxplus.

My xft settings seem to be correct, although when i type ‘root-config --features’ the output doesn’t have xft mentioned anywhere, and again, i am not sure how to change this…

Hi All,

Are there any other suggestions on things I can try? They would be much appreciated :grinning:

copy system.rootrc as ${HOME}/.rootrc and try to change X11.UseXft: yes by X11.UseXft: no

I tried this, but no luck unfortunately…

Then I’m afraid I’m out of suggestions…

One thing I have noticed that may be causing some of the problems is that in the previously linked solution, it says

Check that “UseTTFonts” is set to “true” and that the “TTFontPath” exists and contains something like 33 “.ttf” files.

I have checked this and while UseTTFonts is indeed set to true and the TTFontPath exists, it doesn’t have any .ttf files listed, only 13 .otf files. Could this be causing an issue?

That’s for graphics, not for the GUI…

The root fonts (.ttf files) are in $ROOTSYS/fonts.

When I type echo $ROOTSYS, I get a blank line in return, is this correct?

No, it is not, it should point to your ROOT installation.

even on lxplus?

If you source ROOT from LCG, yes. If you just use the system ROOT installation on an lxplus node (i.e. if which root is /usr/bin/root), then no.

A small update: I haven’t managed to fix this problem yet, however I tried accessing a TBrowser from lxplus on a different machine running ubuntu 20, and had the same issue, which makes me think it is related to ubuntu. I have also tried in the past from windows machines which all work fine.