Adobe helvetica on ubuntu 11.04

Dear rooters,

I just update to ubuntu 11.04, and after a clean installation of root 5.28.00c, I’m getting:

Couldn’t find font “-adobe-helvetica-medium-r---10-----*-iso8859-1”,
trying “fixed”. Please fix your system so helvetica can be found,
this font typically is in the rpm (or pkg equivalent) package
XFree86-[75,100]dpi-fonts or fonts-xorg-[75,100]dpi.

I tried to install many fonts packages but nothing, the problem still.
Could someone point me the correct deb package?

Thanks for any kind of help.


You should verify that the font server (xfs) is installed and running on your machine (ps -aef | grep xfs)

Cheers, Bertrand.

thanks for the reply, it seems tha xfs is running:

What should I do?

Well, more than installing the fonts and having the font server running, I have no idea. I’ll have to try, but it will take time to set-up a virtual machine with ubuntu (I’m working on Windows…)

Cheers, Bertrand.

Oh but wait a minute, you should get something like this:

xfs    1813     1  0 14:06 ?        00:00:00 xfs -droppriv -daemon
lixo1  6837  6717  0 15:10 pts/1    00:00:00 grep --color=auto xfs

So the font server is not running… You should look how to (automatically) start the font server on Ubuntu, it should fix the problem.

Cheers, Bertrand.

You are right, I’m just discovering that xfs is not installed by on my 11.04.
After a sudo apt-get install xfs, I’m getting:

117 1089 1 0 15:45 ? 00:00:00 /usr/bin/xfs -daemon -user debian-xfs -droppriv lixo1 2075 1998 0 15:46 pts/0 00:00:00 grep --color=auto xfs

But the warning persists!

And did you install the fonts?

I installed:

If I should install something else please let me know.

As the message says, the fonts (and not libraries), something looking like XFree86-[75,100]dpi-fonts or fonts-xorg-[75,100]dpi… (I don’t remember and I’m not a Linux expert, but as I managed to get it working, I’m sure you will :wink:)

Ok, thanks Bertrand, it’s working now, here the recipe:

1. Install xfs and xfstt:

2. Install the following fonts:

t1-xfree86-nonfree - non-free Postscript Type 1 fonts from XFree86
ttf-xfree86-nonfree - non-free TrueType fonts from XFree86
ttf-xfree86-nonfree-syriac - non-free syriac OpenType fonts from XFree86
xfonts-75dpi - 75 dpi fonts for X
xfonts-100dpi - 100 dpi fonts for X

3. Reboot

4. Recompile root


You’re welcome! Glad to see you managed to solve the problem. And thanks for the recipe! :slight_smile:

Cheers, Bertrand.

I couldn’t get this to work using the directions posted above. I hope I can just ignore the error.

I was having the same ("-adobe-helvetica-medium-r---10-----*-iso8859-1") problem with a fresh install of ubuntu 12.04 (Precise Pangolin)‎. I followed the above directions and the problem went away (actually I did not have to recompile after installing the new packages).

So this is the full list of packages I installed after a fresh install of 12.04

sudo apt-get install t1-xfree86-nonfree ttf-xfree86-nonfree ttf-xfree86-nonfree-syriac xfonts-75dpi xfonts-100dpi xfs xfstt libXft-dev libXext-dev python python-dev gcc g++ make binutils libx11-dev libxpm-dev libxft-dev libxext-dev build-essential

Dear Experts,
I’m getting exactly the same error message and I’m running on SLC6.
I’m not an expert of linux.

I’ve tried:

sudo yum install xfs
sudo yum install XFree86-[75,100]dpi-fonts
sudo yum install fonts-xorg-[75,100]dpi

and I always get:

Loaded plugins: changelog, kernel-module, protectbase, refresh-packagekit, security, tsflags, versionlock
Setting up Install Process
146 packages excluded due to repository protections
No package name_of_the_package available.
Error: Nothing to do

Can you please give me some hints how to solve this issue on SLC6 ?
Kind regards,

  • Mauro.

On SL[C]6 try (this should give you a good environment for ROOT 5): yum remove qt3 yum install yum-utils yum-builddep cernlib yum install ftgl-devel glew-devel pcre-devel xz-devel yum install fftw-devel gsl-devel python-devel libxml2-devel yum install qt-devel qwt-devel yum install mysql mysql-devel yum install gcc gcc-c++ gcc-gfortran cvs git cmake yum clean all yum check-update yum update
See also: Running ROOT without X font server