TBrowser in batch mode


I’m working with root on remote system (I’m using Visual Studio Code) and I’m trying to open root file via TBrowser command
But it say
“warning in tbrowser::tbrowser: the root browser cannot run in batch mode (tbrowser *) 0x31a3090”
Can you help me to solve the problem?

Welcome to the ROOT forum.

Did you start ROOT with the option -b or have you called gROOT->SetBatch() somewhere in your code?

with the option -b

That’s why you get this message when starting the TBrowser. -b means “Batch mode”. TBrowser needs an interactive session, not a batch one. Do not use -b.

I try without -b but it oesn’t work anyway, it gives me the same error… What can I do?

How do you connect to the remote system?

With ssh, through Visual Code you have the possibility to do it, add a remore account and connect from there

You should start ssh with option -Y

$ ssh -Y

I’ve tryed also from the terminal adding the option -Y but it gives me the same error

You are on windows right ?
If yes, @bellenot might know.

Can you tell us what you are doing exactly? Are you connecting from a Windows machine to a Linux one via ssh? If it’s the case, you need to install a X server (e.g. XMing or VcXsrv) to have graphics. But then I don’t know how to configure all this within VS Code…

I’m using Visual Studio Code. In it you have the possibility to connect with ssh (and save your account) directly from the program. I connected to an account to use root (root is installed in the remore account). When I tryed to give the command “new TBrowser()” from the terminal, it give me the error above.
When I’ve started root i just write “root”.

Thanks, but that was not my question. From which OS are you connecting via ssh and to which OS?

Windows to Linux

OK, then, as I said, you need at least a X server (e.g. XMing or VcXsrv) in order to have graphics

Do you know how to connect Xming with VisualCode?

No, unfortunately. I’m afraid you’ll have to search on the Web (since it’s not directly related to ROOT anyway)

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.