Tab Completion Error

ROOT Version: 6.18
Platform: win10

Whenever i try to use the tab completion after an arrow pointer as seen in the first line in the attached picture, this happens…
Does anyone know why?

Thank you.

That might be either connected to the ROOT version or to the platform (win10). Can you, by any chance, try a more recent version ? @bellenot will be able to tell you if it is a windows issue or not.
I tried on my MacOS platform with the latest ROOT, all is fine.

I’ve tried to install the latest version 6.20 but first upon calling root in cmd, a list of problems appeared, i think they’re related to the compatibility of the windows sdk version i don’t really know …
Is there any suggestion for what should i do?

How did you start ROOT?

1-open cmd
2-go to the dir in which i’m working
3-type root

That’s it.

I can’t reproduce the error… I just tried with ROOT v6.18.00, and here is what I get:

root [0] g->SetM
variable "g" not defined.

variable "g->SetM" not defined.
root [0] g->SetM

I have defined g before as: g= new TGraph();
I also tried other definitions as TF1() too and TCanvas(), i’m still a root beginner… that why i’m using Tab completions a lot.

OK, thanks, now I can reproduce the error, but not always… Apparently, the issue seems to be fixed, at least in the master

Could you try with ROOT v6.18.04? It seems to be working:

  | Welcome to ROOT 6.18/04         |
  |                               (c) 1995-2019, The ROOT Team |
  | Built for win32 on Sep 11 2019, 15:38:23                   |
  | From tags/v6-18-04@v6-18-04                                |
  | Try '.help', '.demo', '.license', '.credits', '.quit'/'.q' |

root [0] g = new TGraph();
root [1] g->SetM
root [1] g->SetM

Same Problem,
The tab completion problem only happens after the arrow pointer,
But i did notice that sometimes(but rarely) it works fine…

OK, and apparently the version 6.20 has the same issue… So sorry, there is not much I can do for the time being…

Well then thank you for your help😊

1 Like

You’re very welcome! :slight_smile:

I found a way to use tab completion without getting this error, say i want to know the tab completion of g->Set… , and assuming g is defined as:
g = new TGraph();

I simply type TGraph::Set and now if i press tab it shows me what i want without an error screen.

I think it’s a good temporary solution pending an update to fix it.
What do you think?

Well, why not, if it works that way. Note that I’m currently trying to find a fix. And you can also use:

root [0] .help TGraph

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.