Subpads not printed

Dear Root support,

I keep having issues when trying to print a pad with a subpad in it via


The printed png file does not contain anything. It seems my pad does not know about the subpads printed in it. I attached a minimal example code where the subpad is coloured green. Test.C (295 Bytes)

Can you help me solve this problem?


I can see the green rectangle on the png.
(On Mac with root5.34)

Hi Couet,

thanks for the reply. I tried it on two machines with two different versions:

Linux with ROOT Version 5.26/00e
Scientific Linux release 5.8 (Boron) Version 5.30/05

A colleague just tried it out on his mac with 5.34 and 5.30 and it worked for 5.34 and failed for 5.30. Could it be a bug in these old versions? Do you know a simple fix for it or do I have to switch to a new version or restructure my code so I don’t need GetPad()->Print() anymore?

So it seems it was fix between 5.30 and 5.34.
That make a long list of log files to check in order to find out when and how it was fixed.
The simplest would be of course to use a more recent version,
If that’s really difficult for your we can to to other solution but let see firs if the simple way can be used :slight_smile:

At the moment I cannot update to a newer version but for an intermediate solution I produce single canvasses and save them. That’s a bit messy but it will do the job until I have the new version. Thanks for the help!