Spurious lines in verbatim output

hi there,

could someone figure out how to customize the email output to not inject spurious lines in “verbatim” copy-paste?
e.g. when I received the mail associated to this post of mine – How to convert root graphs into .dat format? – I got an extra \n after each line of useful content, inside the verbatim snippet.

when I copy-pasted this output:

line 1
line 2

from my terminal into the Discourse verbatim cell, it was correctly displayed inside the web view, but the email showed as:

line 1

line 2

that’s a bit annoying…

could this be fixed?

and here is how it shows up:

am I the only one seeing this?

I have never encountered problems copying and pasting code in discourse…
And I do this quite often … :slight_smile:

how is the following being displayed in your mailer?


The same as in discourse:


hum… me too.
but they weren’t actually copy-pasted (I manually typed them…)

bear with me…

copy-pasted from my favorite browser

$>  root-ls -t /home/binet/Downloads/g4beamline.root 
=== [/home/binet/Downloads/g4beamline.root] ===
version: 61406
TDirectoryFile VirtualDetector VirtualDetector      (cycle=1)
    TNtuple    Det1            VirtualDetector/Det1 (entries=1000)

copy-pasted from my favorite terminal

#---Set name of the project to "ROOT". Has to be done after check of cmake version--------------
set(IntegratedBuild ON)

#---Set the locale to default C to prevent issued due to localization of commands---------------
# This is necessary as we for example call `clang -v` and parse its output. But on a localized
# program, the output parsing is much more error prone as certrain strings we're looking for
# could be missing or be in a different order. To prevent those errors, let's just force all
# output to use the default C locale which is more or less identical on all systems.
set(ENV{LANG} C)

Sorry, but I’m afraid there is nothing we can do here, or at least I didn’t find any option related to that issue…


just to note: I don’t seem to be the only one whose copy-paste renders funny.

see this recent post from @eguiraud:

it renders correctly on the forum but looks funny in my mailer:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.