Sourcing gives broken ROOTSYS variable


~$ echo $ROOTSYS

~$ source $(brew --prefix root6)/libexec/
~$ echo $ROOTSYS
/usr/local/opt/root6 Saving session... ...copying shared history... ...saving history...truncating history files... ...completed.

Any ideas why this environment variable isn’t being set correctly? This is on mac OS Sierra, xcode-select, and the works. ROOT6 compiled and installed just fine. This environment variable is screwing up though.

It appears is incompatible with how the new bash_sessions are implemented in Mac. It seems like that for right now, you cannot have both ROOT6 and bash_sessions… and the fix (which isn’t really a fix, because it’s a bug with ROOT, I think) is

touch ~/.bash_sessions_disable

which tells Mac OS to disable that. And now it seems to work fine in a new shell

Lord Stark:~$ localSetupROOT6 
eLord Stark:~$ echo $ROOTSYS 

I am using Mac Sierra too and I have no problem defining $ROOTSYS using

Putting it in an other way. How do you enable bash sessions?

I just upgraded to mac OS Sierra, and was definitely broken on installing ROOT. I don’t know what you mean by setting up bash sessions, because I’ve never touched that configuration at all.

I do execute

source <root-prefix>/bin/

everyday in my upgraded MacOS 10.12.2 without problems. So, I do no know how to reproduce the problem.