Home | News | Documentation | Download

[SOLVED] IncrementalParser::CheckABICompatibility()

Dear users,

I’ve just moved from ubuntu 15 to ubuntu 18.04 LTS.
ROOT was indeed compiled with the compiler that I had on the ubuntu 15 version (no idea of how to retreive which one it was).
[\code]
Now when trying to compile the easiest code I get:
Warning in cling::IncrementalParser::CheckABICompatibility():
C++ ABI mismatch, compiled with GLIBCXX v20151010 running with v20180720
[\code]
and then a nice segmentation fault.

I’ve seen this post:

and I understand that the compiler I used to compile ROOT at the begninning is not the one which is installed now. Still, I would prefer not to recompile root, since I have other libraries depending on it.
How can I figure out with which compiler ROOT was compiled?
Is this work-around still valid?
[\quote]
gSystem->SetMakeSharedLib((TString(gSystem->GetMakeSharedLib())).ReplaceAll("g++ ", "g+±4.8 ").Data());
[\quote]

Thank you very much for your help
Cheers
Paola


_ROOT Version: 6.04
_Platform: ubuntu 18.04
_Compiler:/usr/bin/gcc -> gcc-7 , so I think 7.3 but I not sure.


I think you need to recompile ROOT using this new compiler.

Just grab the Ubuntu 18 build from here: https://root.cern.ch/content/release-61404

Thank you Axel!
Cheers
Paola

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.