Setting the TLegend symbol size with option “l"


I cannot find how to change the size of the symbol in a TLegend when it’s entered with option “l”, line. It happens that the line symbol is very large and most of the space of the legend is for that: so the text, that is very long in my case, is little and unreadable. I can change the font size, but then the text will go out of the Pad dimension. One option could be to wrap the text into two lines, but again I cannot find the command to do it.

Can you please help me?
Thanks, cheers

To make you legend od 2 lines you can have you lgend text like:


It will be helpful if you can send a macro reproducing what you get.