Setting new root version as default


I’m trying to update my ROOT version on my linux ubuntu VM.
I have several versions available, but can not seem to set the one I wish as default i.e.:
current version: ROOT/5.34.26/x86_64-slc6-gcc48-opt/root/bin/root

And I want to set this as default when I open/use root:

I am new to both ROOT and linux, thanks in advance!

Something like that should work:

. ROOT/6.06.08/x86_64-slc6-gcc49-opt/root/bin/

The command seem to have worked, but now root wont open, when I type root in terminal:
“root: /cvmfs/ version `CXXABI_1.3.8’ not found (required by root)”

Did I assume wrongly that the version was available since it is shown in the directory?

It looks like the command did not set the environment variables correctly. What is the value of $ROOTYS after you sourced this script ?

slc6 is for “Scientific Linux CERN 6” linux distribution, not Ubuntu.
You need to use Ubuntu-compatible version of root binaries.
ROOT 5 for SLC6 may have worked in Ubuntu, but ROOT 6 is unlikely to work this way.

I checked my version - my bad!

I do actually run SLC.

doing echo $ROOTSYS and it says:

You’ve loaded the x86_64-slc6-gcc49-opt version of ROOT, but you have gcc 4.8.1 active.
Try to . /cvmfs/

Thanks alot, this worked!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.