Root version compatible with pythia 8180

which root version i should use with pythia 8180 ??
i want my pythia histogram output in root format.

You should build ROOT from source…
Cheers, Bertrand.

i had built root from source using instructions from

Good! And then?

and then reconfigured it using

--enable-pythia8 --with-pythia8-incdir=$PYTHIA8/include --with-pythia8-libdir=$PYTHIA8/lib

and i am having a problem in interfacing root with pythia8.

But did you rebuild ROOT after having reconfigured? Otherwise it won’t work…

i run

make make install

after that

And what is the problem afterwards?

i had mentioned it in

can you have a look??

Well, I’m already replying to that thread… :-k

yes, you are .
Thanks :slight_smile:

also when i tried to run

i got error as:
Error in TUnixSystem::DynamicPathName: libEGPythia8[.so | .dll | .dylib | .sl | .dl | .a] does not exist in /home/raman/Downloads/root/lib:/home/raman/Downloads/pythia8180//lib:/home/raman/Downloads/root/lib:.:/home/raman/Downloads/root/lib::/home/raman/Downloads/root/cint/cint/stl
Error: Symbol TPythia8 is not defined in current scope pythia8.C:45:
Error: Symbol TPythia8 is not defined in current scope pythia8.C:45:
Error: type TPythia8 not defined FILE:/home/raman/Downloads/root/tutorials/pythia/./pythia8.C LINE:45
Error: Invalid type ‘TPythia8*’ in declaration of ‘pythia8’ pythia8.C:45:
*** Interpreter error recovered ***

So this means that libEGPythia8 has not been built… Are you sure that ROOT found the Pythia8 headers and library? At the end of configure, it should print pythia8 in the list of “Enabled support for …”. For example on my PC:

Enabled support for asimage, astiff, builtin_afterimage, builtin_ftgl, builtin_freetype, builtin_glew, builtin_pcre, builtin_zlib, builtin_lzma, castor, cintex, explicitlink, fftw3, fitsio, gviz, gdml, genvector, mathmore, minuit2, mysql, odbc, opengl, oracle, pythia6, pythia8, python, qtgsi, reflex, roofit, rfio, ssl, table, tmva, unuran, vc, vdt, xml.
And while configure is running, at some point it prints (for example on my system):

... Checking for Pythia8/Pythia.h ... c:/Users/bellenot/libs/pythia8/include Checking for libpythia8 ... c:/Users/bellenot/libs/pythia8/lib/Release ...
So please make sure it finds it, otherwise give the correct path to configure and try again. At the end, libEGPythia8 should be in $ROOTSYS/lib…

i run

i end of output i got

./configure --enable-pythia8 --with-pythia8-incdir=$PYTHIA8/include --with-pythia8-libdir=$PYTHIA8/lib And make sure $PYTHIA8 is valid and points to your Pythia8 installation dir, or give the correct path to --with-pythia8-incdir and --with-pythia8-libdir

What is the output of

the output of


when i used

but the output still is:

Enabled support for asimage, astiff, builtin_afterimage, builtin_pcre, builtin_lzma, cintex, exceptions, explicitlink, genvector, memstat, reflex, shadowpw, shared, tmva, x11, xft.

What is the result of ls $PYTHIA8/include and ls $PYTHIA8/lib

the output of


and output of


OK, so Pythia8 looks fine. could you post the $ROOTSYS/config.status and $ROOTSYS/config.log files?