ROOT instalation Error & Make j-4 not Running

I properly installed all libraries, dependencies & Prerequisties for the installation of CERN Root on my Ubuntu but unfortunately my installation stucks on make -j4 command
i tried make-j, make -j2,
make -j3,
make -j4,
make -j5,
make -j6,
make -j7,
make -j8,
make -j9,

but unfortunately i saw the same error which is mentioned:

CMake Error at /home/rat/ROOT/root-6.20.02/rootnew/AFTERIMAGE-prefix/src/AFTERIMAGE-stamp/AFTERIMAGE-build-Release.cmake:49 (message):
Command failed: 2


See also


make[2]: *** [CMakeFiles/AFTERIMAGE.dir/build.make:130: AFTERIMAGE-prefix/src/AFTERIMAGE-stamp/AFTERIMAGE-build] Error 1
make[1]: *** [CMakeFiles/Makefile2:7525: CMakeFiles/AFTERIMAGE.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs…
[ 27%] Built target hist2workspaceMan
[ 27%] Built target rootclingMan
[ 54%] Built target move_artifacts
make: *** [Makefile:171: all] Error 2

kindly guide me how to solve this in simple and easy way.
in case if i need to install anything else then please share the procedure from scrap


Welcome to the ROOT forum.

What was your cmake command ?

cmake … is my command . execution is fine

you do not have any options passed to the cmake command ?

i followed following commands:

mkdir root

cd root
cmake …
all thing are fine then

make -j4 etc is showing error

What exactly did you use as “”.

i used cmake … nd its working good but i have problem about make -j4

The building output explicitly says that you should inspect “AFTERIMAGE-build-*.log” files, which may contain hints about what went wrong.

Actually, ROOT 6.20/02 is quite old.
You may have more luck if you try the latest release.

I have seen this type of error often when updating my git repo and then building again.
I solve it by calling make clean and then make again. Maybe is something else, but worth a try.