ROOT for macOS 10.14

Dear ROOT team,

I think I read somewhere in the forum that the master version is now compatible with Mojave. Nevertheless, I would prefer to install a stable version. Do you know when the next ROOT 6.14 will be available (which I suppose will compile under Mojave) or should I really go for the master (I definitely need something rapidly :slight_smile: ) ?

By the way, I may have missed it but it could be interesting in the download section to have an estimate of the release date of the next ROOT version (I don’t know if this makes sense from the developper point of view but for the user that would be interesting,)

Thanks in advance,

ROOT Version: 6.14
Platform: macOS 10.14
Compiler: Not Provided

Tag releases are usually created based on necessity, so duration between them can vary a lot. However, the regular releases come usually around May and November of each year.

there is one particular widget that seems broken: TGTextView
it works in interpreted mode but not in compiled mode.
an example macro is attached. I use the following to compile

clang++ -g -I. -O2 -std=c++11     -I/opt/local/include/ -I `root-config --incdir` -O -Wall -fPIC 
  denc.C -o aaa.exe -L/opt/local/lib/ -lgsl -lGeom  -lm `root-config --glibs`

denc.C (2.5 KB)

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.

@bellenot could you have a look?


It works for me on Linux and Windows (master branch). Unfortunately, I cannot test on Mac. Maybe @couet could give it a try and let us know?

Cheers, Bertrand.

I just tried on my Mac (which is also running MacOS 10.14) and it works for me. Both in interactive mode (at the ROOT prompt) and compiled mode (using the command you posted).

BTW, could you describe what exactly doesn’t work?

Please see the attached screenshot.
The compiled version doesn’t display the initial message in the output window, BUT the interpreted version does (bottom part).

So here is what I got on Linux:
And on Windows:

Yes I get the same.

But I get that with the compiled version and in interpreted mode. This is with the Cocoa version of ROOT. With the X11 version it is fine. I have no idea right now why it behaves differently with the Cocoa version. I have tried to add gSystem->ProcessEvents(); after the window mapping but it does not help.

May be @tpochep has some other idea to suggest ?

Both interpreted and compiled versions should have displayed the message correctly.
You say it is ok with X11 version. I don’t understand what you mean by that. 1) could you share a screenshot? 2) how do I switch to that version?

On Mac you can install ROOT with 2 different graphics backend.

  1. Cocoa:, which is the native Mac graphics system
  2. X11, the standard X-Window graphics system

By default ROOT is installed with Cocoa. To have ROOT running with X11 you will need to reinstall ROOT on your machine. Have you installed ROOT yourself on your Mac ?

I asked @tpochep, the author of the Cocoa backend, if he has some idea about this problem. May be he can suggest some workaround.

BTW, you could add the following lines in your MyApplication constructor, to properly close the application in compiled mode:

#ifndef __CLING__
   Connect("CloseWindow()", "TApplication", gApplication, "Terminate()");

Cheers, Bertrand.

Yes I compiled from the sources.

So you can add the two following options in the cmake command:

-Dcocoa=OFF -Dx11=ON

This will disable the Cocoa backend and enable the X11 one.

You need also to make sure you have X11 installed on your Mac.
You should get it from here:

I confirm that compiling with these two directives, the output panel is now working.

Thank you very much.
Please let us know also when the “default” version is fixed.

Please I’m new in both MACOS and ROOT, I tried versions of root but no one worked, So I have MacOS Mojave 10.14, I just downloaded the latest version of root 6.16.00, I tried in summer with 5.34 , because I’m not familiar with root or mac , my supervisor in Spain did for me the setup, and created the variables environnement, the browser didn’t work, so I installed by my self root 6.14 with removing 5.34 or changing variables environnement, returned back to my country , no one uses both mac and root, a friend of me sent to a macros, I faced problems to open it, so I removed root 5.34, lest just root 6.14, same problems , now I removed root 6.14 and trying with root 6.16, I changed .profile when I’m typing root in the terminal, errors show up, new file not found…etc, With folder I should use, I download the three of them from Root website,
OsX 10.14 clang100|root_v6.16.00.macosx64-10.14-clang100.dmg|131M
OsX 10.14 clang100|root_v6.16.00.macosx64-10.14-clang100.tar.gz|130M
source root_v6.16.00.source.tar.gz 157M
Please help me, I’ wasting time and it’s burning my neurons
Thank you for your time,
have a nice day,
Best wishes,