Root font issue

I have ROOT 6.24 and I have compiled it from source on void linux. I am having this weird font on my histograms. Even if I try to change, it stays the same. I have deleted everything and recompile a couple of times. Does anyone have any idea, why is it so? I also tried to tweak using .rootrc but nothing changed.
I have a similar installation on the same platform on another system where everything is fine.

May be you have a rootlogon.C file setting this font. Try to start root with the option -n.

1 Like

Thanks for the reply. Nothing changes with the -n option.

The folder $ROOTSYS/fonts should be:

% ls $ROOTSYS/fonts
BlackChancery.ttf	FreeSansOblique.otf	STIXGeneralItalic.otf	STIXSiz5Sym.otf		courbd.ttf		symbol.ttf		verdana.ttf
DroidSansFallback.ttf	FreeSerif.otf		STIXSiz1Sym.otf		arial.ttf		courbi.ttf		times.ttf		verdanab.ttf
FreeMono.otf		FreeSerifBold.otf	STIXSiz1SymBol.otf	arialbd.ttf		couri.ttf		timesbd.ttf		verdanai.ttf
FreeMonoBold.otf	FreeSerifBoldItalic.otf	STIXSiz2Sym.otf		arialbi.ttf		georgia.ttf		timesbi.ttf		verdanaz.ttf
FreeMonoBoldOblique.otf	FreeSerifItalic.otf	STIXSiz2SymBol.otf	ariali.ttf		georgiab.ttf		timesi.ttf		webdings.ttf
FreeMonoOblique.otf	LICENSE			STIXSiz3Sym.otf		ariblk.ttf		georgiai.ttf		trebuc.ttf		wingding.ttf
FreeSans.otf		STIXGeneral.otf		STIXSiz3SymBol.otf	comic.ttf		georgiaz.ttf		trebucbd.ttf
FreeSansBold.otf	STIXGeneralBol.otf	STIXSiz4Sym.otf		comicbd.ttf		impact.ttf		trebucbi.ttf
FreeSansBoldOblique.otf	STIXGeneralBolIta.otf	STIXSiz4SymBol.otf	cour.ttf		monotype.ttf		trebucit.ttf

these are the fonts in /usr/share/root/font

Yes, but what about $ROOTSYS/fonts ? this is where ROOT looks for fonts.

echo $ROOTSYS outputs nothing, but that maybe because I dont source any shell script to load root. I have it in my /usr/bin/. But even when I export $ROOTSYS to /usr/share/root and ls $ROOTSYS will give the fonts I attached in the screenshot above, nothing changes.
I fixed the problem though thanks to the comment above with all the font name. I copied all the font from /usr/share/root/fonts on my other machine to this one. Everything works fine. Thank you so much

It should be defined. You should source the script in the bin folder where root is.

okay. i sourced the script but echo $ROOTSYS still doesn’t output anything. Should I manually define it and what directory should it point to?

That’s weird.
you did that:

cd bin-folder-where-root-is


1 Like

it is indeed but that is because ROOT is not installed in a single directory. That is because I did “sudo make install” after “make”. Things are scattered in the /usr directory. Thats why I dont source the .sh file because everything works without doing it.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.