Root cannot find Minuit2Minimizer.h or GSLMinimizer.h:


I can run a macro using Minuit2 and GSLMinimizer on one machine, but not another. The error message is: error: Math/GSLMinimizer.h: No such file or directory error: Minuit2/Minuit2Minimizer.h: No such file or directory

I compile as .L on a MacOS 10.6.8.

locate GSLMinimizer.h Minuit2Minimizer.h gives me:

I tried adding these paths manually to PATH, LD_LIBRARY_PATH, DYLD_LIBRARY_PATH even ROOTSYS, so that isn’t it. I tried copying the .h files into the working directory and explicitly typing out the path in the #include, but neither worked.

Anyone have avice?

Warren Harding

Try “root-config --features” and see if the output contains “mathmore” (for GSL) and “minuit2”. If not, you need to rebuild your ROOT from scratch, configuring it with “–enable-mathmore --enable-minuit2” (note: “binary” and “development” packages of a GSL version >= 1.8 required). After the “configure” step, make sure that the “config.log” file contains “Result: Enabled support for … mathmore, … minuit2, …” somewhere near its end.