ROOT-Build Fail on MacOS 12.1


I’m trying to build root on macOS v12.1 with these options:

cmake -DCMAKE_INSTALL_PREFIX=…/install/ …/root_src/ -Dminuit2=ON -Dpyroot=ON …/root_src/

And see this error:

[ 48%] Generating G__Core.cxx, …/lib/Core.pcm
error: entry with relative path at the root level is not discoverable
{ ‘name’: ‘’, ‘type’: ‘directory’,
Error in modulemap.overlay!

Does anyone understand this?

It seems like there are other threads:


perhaps someone can advise. See I have a previous version of ROOT install and it worked on MacOS 12.1 until I updated XCode. So is there a way to just use that build if I just reverted back to the older version of XCode?

So it seems there’s no way to install any form of root on MacOS12.1 … is this correct?

In that case I installed the docker image…is it possible to use the docker image to look at data stored locally (I mean in a TBrowser or for analysis)?

Which version of ROOT are you trying to install ? I have the master branch and 6,.26 branch working on 12.1 and latest XCode. You need to make sure you start with a clean build and using system libraries. Otherwise you can also use binary builds nightly from Index of /download/nightly




it was the latest version, from source. I tried several things and none worked (source, brew, latest binary) and none worked. I have XCode 13 (since 13.1 didnt work and one of the other threads suggested switching back) and MacOS12.1. I’d rather have it from source since I want to use minuit2 but its not essential, I can find another machine to work on if I need to use that. In the end I was able to get this version to work: . I’m not sure why it worked and others didnt though.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.