Failed module loading when importing ROOT as a python package

I am very new to ROOT. I want to import it into an anaconda environment. ROOT has already been downloaded within this environment . However, when I attempt an import I receive a “‘Darwin’ uses additional module map error”(see picture). This is followed by a series of failed loaded modules. It should be noted that I have xcode downloaded in addition to the command lines. Some(perhaps) useful specifications:

Python: 3.10.4(within anaconda)
conda: 4.12.0
Xcode: 13.3.1

_ROOT Version: 6.26.02
_Platform: Mac OS Monterey 12.3.1
Compiler: Not Provided

Welcome to the ROOT Forum! If you search this forum, you will find several topics related to the same issue, and most probably find the solution to it (this is one of the purposes of the forum)

Thank you! The thing is I’ve been through this entire discussion thread and tried every suggestion. I have tried various versions of Xcode, deleted and re-downloaded root and tried various versions of python. Still receiving the same error. Any further suggestions for a newbie would be highly appreciated!:slight_smile:

Then I’ll ask a Mac user ( @couet , @Axel ) to take a look at this

I can just tell what I am doing.
I have:

  • Python 3.8.9
  • Xcode 13.3.1
  • MacOs 12.3.1
  • Install ROOT master 6.27/01
  • cmake flags: -Dhttp=ON -Droot7=ON -DCMAKE_CXX_STANDARD=17 -Dall=ON -Dbuiltin_xrootd=ON

etc. @vvassilev is there a solution to this now?

Yes, Fix running with macOS 12.0+ SDK after building with an older SDK by chrisburr · Pull Request #10555 · root-project/root · GitHub

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.