Root 6.26.00 installation difficulties on Mac

Hi everyone,

I am completely new to the world of programming and using different programs and so on. I am working on my bachelor thesis for the JUNO experiment and in order to run some codes given to me, I need the following programs:
C++ compiler, standard >= 11
tested with gcc 4.9.4
tested with gcc 4.8.5
tested with gcc 11.3.0

cmake >= 2.7.0
	tested with 3.7.0
	tested with 3.10.0-rc2
	tested with 3.22.1
	tested with GNU Make 3.81 (2006)
	tested with GNU Make 3.82 (2010)
	tested with GNU Make 4.3
	tested with 5.32
	tested with 6.10
	tested with 6.26/06

Now via homebrew I already installed make and cmake. I also have Xcode as a C++ compiler. With root, the problems begin. I tried using brew install root which gave me the newest version of root but the data processor I’ll have to use was only tested on root 6.26, which I would like to install now. I’ve tried for a few days now, with chatgpt, with other internet tips, with tips from people at my university, but there are always so many different error messages that I won’t even start to understand, so I was just wondering if anyone had to install an older version of root as well and how they did that.
I downloaded root 6.26.00 and put it in a separate folder called “Root” so I could quickly access it through the terminal (I’m using a MacBook Pro). I keep getting error messages about so many different things like
‘/opt/homebrew/bin/gmake’, Please enable builtin Glew due bug in latest CMake (use cmake option
-Dbuiltin_glew=ON). (which I did…) and so on. I’m so frustrated at this point.
someone suggested ccmake but I can’t even find anything on the internet on how to install that on mac, so…
any help would be appreciated!

ROOT Version: Not Provided
Platform: Not Provided
Compiler: Not Provided

Hi @Wandelsterne,

Welcome to the ROOT forum.

We indeed don’t recommend building ROOT from source if you’re a beginner. What you can do instead, if you need an older ROOT version, is to download the binary file (i.e. a ready to use programme) from here: Releases - ROOT (just select whichever version you need and whichever operating system version you are using). Then simply follow the instructions here: Installing ROOT - ROOT.

In case you still have issues, please let us know.


Hi, thank you for the quick response!
I downloaded the binary file but now I have another problem… my Mac refuses to let me properly set up root because it is neither from the App Store or “verified developers” so I can’t run the command “root” without getting error commands. Is there any solution to this?

Edit: I don’t know if this is relevant but I’m working with macOS14 and xcode 15.0.1 and the binary distribution I installed was for macOS12 and Xcode 13. would that still work?


this can be fixed by changing your macbook’s permissions, for example: Allow accessibility apps to access your Mac – Apple Support (UK). (If you google the exact error message you’re getting you should be able to find more answers).


sadly this didn’t work for me because I kept getting the error message for one program that it wasn’t from the App Store or a trusted developer and the settings app ended up bugging around and closing itself. I tried again to redownload the binary distribution the way it was described but now I have root 6.28., lol. I feel stupid for not being able to figure this out but sadly nothing’s really working for me with this program


ok, I see, actually I found a forum post with the same issue as yours: Mac 10.15 Catalina: "cannot be opened because the developer cannot be verified"

What I did just now on my macbook (and it works) is running the following in the terminal:
curl -O

Then you follow the installation steps in a new window.
By default, your new ROOT executable should be installed in the Applications folder. Then from there you will still need to source file as:
source /Applications/root_v6.26.99/bin/

Then you can just type root in your terminal in order to start an interactive session.


1 Like

hi, thank you once again for your answer. in theory, this works really well, however it seems like whenever I’m restarting my pc or closing my terminal, root “disappears”. it worked before but when I type root in the terminal, there’s an error message. I had to reinstall via curl and it’s honestly quite a hassle. do you know why that is or how I can avoid that?

ok nvm I just de- and reinstalled but now it doesn’t work anymore. I can’t find it in my applications.


and have you sourced root in your new terminal? You don’t have to reinstall it every time but you do need to source it every time.

Regarding your second question, I have no clue what happened on your machine… maybe the installation path has changed?


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.