Mac 10.15 Catalina: "cannot be opened because the developer cannot be verified"

Dear all,
I updated my macbook from Mojave 10.14 to Catalina 10.15.1, then when I want to open the root in the terminal I am facing with message ( “root” cannot be opened because the developer cannot be verified.) could anyone of you help me with this matter please? By the way, I had tried for many time to solve this problem from security&privacy by clicking on “allow anyway” button but, still the problem is remained.
Thank you.

How does work for you? I did not see an issue with developer verification, and I do have SIP enabled.

Thank you for your advising Alex, Yes I followed the procedure that you suggested but, still the problem is not solved because I think this MacOs Catalina (version 10.15.1) do not allow the root program to be opened in my operating system. Whilst, every time I permit that by clicking the the Allow Anyway button and another message appears which is macOS cannot verify the developer of “”. Are you sure you want to open it?

I am really regretted from upgrading to the MacOs Catalina 10.15.1 because previously I was working with MacOs Mojave 10.14 without any problem.

Dear lain_Bertram1,

Your suggestion is right but it still has problems! personally in my system which are:

1- I cannot use the Root Macros in this circumstance.
2- Every time after closing the terminal when I want use the root, must repeat this cycle from the first point.

The files from should not be called - are you sure you are using the right ROOT build, the one you installed from the downloaded pgk file?

What do you do exactly that triggers the message that requests you to “allow anyway”?


Try opening terminal and paste :
sudo spctl --master-disable and insert your admin password
then open System Preferences - Security and Privacywhere you should see the option to allow apps from ‘anywhere’ . Try to select that and relaunch root .
Let me know if it was helpful

Hi Axel,
Thank you for your kind corporations. According to your instruction, I downloaded the exact pkg file that you sent me in the link above, but it did not work in the case of my computer (it can be installed completely but after installation disappears).
I do not know where the problem is. Whilst, every time I also cloud be able to install the Root in the terminal of my system. The main problem comes from the point that when I am trying to run root in the terminal (after completing the installation of the Root) a window appears as you can check bellow in the attached image:

That should really not be needed. I have a mac with SIP etc enabled, and I can use ROOT from the binary. I’d like to understand what we need to fix on the ROOT side instead of asking people to hack around macOS’s safety features…

Cheers, Axel.

Now I cannot even install the pkg anymore without working around Gatekeeper. I wonder what happened between then and now. OK - we’ll look into signing. This is a mess :frowning:

As a work around that does not globally disable the security features of your Mac, please try to following:

Does that work for you?


Folks, there’s a wonderfully trivial workaround - at least for now :slight_smile:
Download the installer package (e.g. through curl:

curl -O


1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.