Home | News | Documentation | Download

Remote X11 session fails - XQuartz crashes when forwarding ROOT graphics

Hi,

I have a really unusual problem, and I do not have a better guess than this is connected somehow to ROOT.
I try to do ssh tunneling from a scientific linux server to mac (see details at end) by

ssh -XY user@server

(or variants of -X and -Y)

All authentications are correct, config files checked, xauth OK, DISPLAY environment seems ok.

Most importantly I can tunnel trough ALL X windowsI tried (xclock, xeyes, geany, emacs…), but it fails with ROOT.

When trying to launch a root application with a TCanvas (or from cint a TBrowser, or anything with ROOT graphics), a window blops up for a (milli)second and then XQuartz on my side crashing.

In verbose session (ssh -XY -v) the output after launching the ROOT application is:


debug1: client_input_channel_open: ctype x11 rchan 3 win 65536 max 16384
debug1: client_request_x11: request from 129.129.141.177 53580
debug1: x11_connect_display: $DISPLAY is launchd
debug1: channel 1: new [x11]
debug1: confirm x11
Socket accepted

Error in RootX11IOErrorHandler: fatal X11 error (connection to server lost?!)

**** Save data and exit application ****

Which is just showing the XQuartz crash after trying to launch a window.
I could reproduce this error with all the other scientific linux machines I have right now access to.
It looked like a segmentation fault in XQuartz on my local Mac, but I reinstalled, used more XQuartz versions, all producing the same…

I was hoping some of you might have an idea, even just steps of troubleshooting?
What is the difference between and XWindow opened for ROOT, and other interactive sessions like xeyes?


_ROOT Version (on server): 5.34/36
_Platform (on server): Scientific Linux release 6.9 (Carbon)
_Compiler (on server): gcc version 4.4.7 20120313 (Red Hat 4.4.7-18) (GCC)
_Platform (on client): Mac OSX 10.14.3 (Mojave)
_Compiler (on client): Apple LLVM version 10.0.0 (clang-1000.11.45.5)

Hello,

I am experiencing the same problem unfortunately!

1 Like

is it ROOT only ? does xterm or some other X11 application work ?

yes, all other x windows seem to open whithout a glitch (tried: xterm, xclock, xeyes, emacs with gui…)
I’m really puzzled.

PS: as you see from the verbose output, all authentication passes, new x11 confirmed, socket acccepted - then, XQuartz is crashing. Only from ROOT so far. In the crash report I see segmentation faults. I went trough many XQuartz related troubleshooting steps (complete cleanup, reinstall, tried older versions, checking config files on both sides, environmental variables…) but, XQuartz (2.7.11) really seems to work perfectly up to the point when it opens a ROOT window.

We just checked that a colleague with a Linux machine (connecting to the scientific linux server) does not have the same problem, so the problem must be with the mixture of ROOT(5.36) and XQuartz(the latest 2.7.11 and older versions down to 2.6). It might be related to the relatively new Mojave OSX too

Do more recent ROOT versions have the same problem ?

Yes, the problem is the same with the latest root5 (5.34/38) (on lxplus CERN) as on these 5.34/36 (on SLC 6.9 Carbon at PSI)

I have no means to update to root6 on these remote machines, as they are part of a more complex DAQ (and this would not solve the problem, as upgrading the DAQ with root6 is unlikely). Unfortunately I could not even test root6 yet, apparently all my colleagues are still with root5 on the DAQ machines.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.