Question related to Parallel coordinate plot

Hello all,

I am making a plot using parallel coordinate plot like:

tree->Draw("x:y:z","","para");

But the range of x, y and z are different, and I would like to make their range common.

I tried few functions like SetGlobalScale(), SetGlobalMin(), SetGlobalMax(), etc from root.cern.ch/root/html/TParallelCoord.html but they are not working.

So, please suggest how I could set their range common.

root [0] ntuple->Draw("px:py:py","","para");
root [1] TParallelCoord* para = (TParallelCoord*)gPad->GetListOfPrimitives()->FindObject("ParaCoord");
root [2] para->SetGlobalMin(-10)
root [3] gPad->Modified()

Thanks couet. It worked.

I have one more problem with this, If you look at the plot cluster_position_0.pdf (19 KB) then the lines are not passing from the center of the drawn histogram bins. I am expecting that corresponding to each entry in the axis the line will originate from there only but the histogram and lines seems to be at different places. I don’t know what is happening there. Do you have idea what’s the problem?

In the plot only minimum and maximum value of axis is shown but I would like put all the values of axis in steps of 10 or so. So, how could I do this?

with regards,
Ram

Seems to me you are trying to use the ||-Coord as an histogram plotter.
The histograms are only an option … in principle they are not need…
Yes only min and max are plotted … Do you really need the lines ? if not, use histograms … not ||-Coord

See en.wikipedia.org/wiki/Parallel_coordinates

Dear couet,

I got your point. But, the problem is that the TParallelCoord is plotting both simultaneously, histogram as well as parallel coordinates. And then from the plots it looks confusing that what’s happening. I mean where did particle hit my detector either at the place where line originates or the histogram is there.

Yes, lines are necessary for me. Since I have three detectors and I would like to know the path of particles so line will help me in this.

If there is a possibility to remove histograms and I get only lines then its also fine with me.

with regards,
Ram

In the GUI: Variables -> the unset “Show box histograms”