Problems with RooStats tutorial 101


I am trying to use the RooStats tutorial #101 (rs101_limitexample.C). I am using root 5.22 (set up through CMSSW_3_8_2). I have been having a lot of trouble getting the header files to load. I tried to include the path to the lastest roofit header files in $LD_LIBRARY_PATH and the root gSystem include path. Neither of these worked properly. Any suggestions?

For the time being I have copied the relevant heading files into my local area so that they load properly. However, when I tried to run the script it gave me an error. At first in complained about how the function ModelConfig::ModelConfig was being called in line 98. I fixed this by passing the name of the RooWorkSpace instead of the pointer. ie by replacing:

ModelConfig modelConfig(new RooWorkspace());


RooWorkspace* test = new RooWorkspace(“test”);

ModelConfig modelConfig(“test”);

But I am not sure why passing the point of the RooWorkSpace didn’t work. Any ideas?

Lastly I am also getting this error:

Error: Can’t call ModelConfig::SetParametersOfInterest(paramOfInterest) in current scope rs101_limitexample.C:102:

Is it possible that I am using a version of ModelConfig.h that is incompatible with this script?


I solved this problem. It seems to have been due to the version of RooFit being different from the version of Root I was using.