Problem while building root from source

As I was trying to download the Dependencies (Dependencies - ROOT) for building root I came across multiple errors

Note, selecting ‘libglu1-mesa-dev’ instead of ‘xlibmesa-glu-dev’
Note, selecting ‘libgraphviz-dev’ instead of ‘graphviz-dev’
Note, selecting ‘python-dev-is-python2’ instead of ‘python-dev’
Note, selecting ‘libgsl-dev’ instead of ‘libgsl0-dev’
E: Unable to locate package libglew1.5-dev
E: Couldn’t find any package by glob ‘libglew1.5-dev’
E: Couldn’t find any package by regex ‘libglew1.5-dev’

seems like error is in libglew 1.5 package if I’m not mistaken. When I try to download these dependencies in ubuntu 20.04 no error occours. I think ubuntu 22.04 stopped supporting python 2 and libglew1.5 so that can cause an error. Can anyone solve this problem or is there anyone who’s also facing this problem

ROOT Version: 6.26
Platform: Ubuntu 22.04
Compiler: Not Provided

You don’t need to compile ROOT, unless you have a specific reason why. Normally, you should just download a precompiled binary: go to Download at the top of this page, click on the “latest stable ROOT release”, and choose the appropriate tar.gz from “binary distributions” (in your case, the file for Ubuntu 22.04), uncompress it and then just run /path/to/root/bin/ every time before running root (or add it to your .bashrc file).
In any case, even without compiling, I run these before installing ROOT:

 sudo apt update
 sudo apt install -y build-essential
# for ROOT:
 sudo apt install -y xfstt t1-xfree86-nonfree ttf-xfree86-nonfree ttf-xfree86-nonfree-syriac xfonts-75dpi xfonts-100dpi
 sudo apt install -y git dpkg-dev cmake g++ gcc binutils libx11-dev libxpm-dev libxft-dev libxext-dev

Hi thanks for help. I did all the steps and finally I ran bash in bin folder and this is what I got

./ line 168: ${(%):-%N}: bad substitution
maybe I messed up with system. I had installed root earlier from source code and deleted the file now trying this way.

Do “source”, not “bash”.

1 Like

Thank you so much!! I got it!! cheers

I have created clarify error message with bash by ferdymercury · Pull Request #11530 · root-project/root · GitHub to clarify a bit the error message. You could use “bash” instead of “source” if you had extdebug option enabled.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.