Problem when compiling macros with root_v6.14 under Windows 10

Hi everyone,

After installing the windows version of root 6.14 on my PC, I tried to compile one of my macro files, but I ran into a strange error message:

C:\WINDOWS\System32\KERNEL32.DLL : fatal error LNK1107: invalid or corrupt file: cannot read at location 0x2F0.Error in ACLiC: Compilation failed!

If I only use the interpreter mode, the macro runs fine.

Has anyone seen such error message in relation with root 6.14 on windows?


ROOT Version: 6.14
Platform: Windows 10
Compiler: Visual studio 2017


How did you compile it?

Just the usual way:

.L macro.C+

OK, that’s weird… Could you attach the full log? And I suppose you run in a x86 Native Tools Command Prompt for VS2017, right?

Yes, I am running Root from the y86 Native Tools prompt.

Here is the full log (sorry for the partly German messages):

D:\M36\test>root -l
root [0] .L SoftKAM_v9_9_3.C+
Info in TWinNTSystem::ACLiC: creating shared library D:/M36/test/SoftKAM_v9_9_3_C.dll
D:/M36/test/SoftKAM_v9_9_3.C(890): warning C4101: “scale”: Unreferenzierte lokale Variable
D:/M36/test/SoftKAM_v9_9_3.C(905): warning C4101: “TDiffBetaGamma”: Unreferenzierte lokale Variable
Bibliothek “D:/M36/test\SoftKAM_v9_9_3_C.lib” und Objekt “D:/M36/test\SoftKAM_v9_9_3_C.exp” werden erstellt.
C:\WINDOWS\System32\KERNEL32.DLL : fatal error LNK1107: Ungültige oder beschädigte Datei: Lesen bei 0x2F0 nicht möglich.
Error in : Compilation failed!
root [1]

The code sucessfully creates the .lib and .exp files, then comes the above mentioned error message (in German), and then the compiler fails.

Thanks for the log. And sorry, but I’ve never seen such problem… I’ll try to guess what could be the issue and come back to you

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.