KERNEL32.DLL fatal error while using ROOT 6 & Windows10

Hi All,

I am currently facing a problem when compiling code with ROOT 6.18/00 (debug binary). Every time I try to compile a macro or a set of libraries, I get the following error:

C:\WINDOWS\System32\KERNEL32.DLL : fatal error LNK1107: invalid or corrupt file: cannot read at 0x2E0
Error in <ACLiC>: Compilation failed!

I compile using a x86 Native Tools Command Prompt through the command .L macro.cpp++
I get the same error if I compile from Visual Studio directly or calling the VCVARSALL.BAT from a normal cmd prompt.

Just to be sure I built again root in my PC (using cmake) and also in this case I get the same error.
My Visual Studio configuration is the following:

  • MSVC v142 - VS2019 C++ x64/x86 build tools
  • Windows 10 SDK (10.0.18362.0)
  • Windows 10 SDK (10.0.17134.0)
  • Just-In-Time debugger
  • C++ profiling tools
  • C++ ATL for v142 build tools (x86 & x64)
  • Test Adapter for Boost.Test
  • Test Adapter for Google Test
  • IntelliCode
  • C++ Clang tools for Windows (8.0.0 - x64/x86)

Searching in the forum I have found other two posts with similar error:


I would be so grateful for any help! :slight_smile:

Thanks a lot,
Matteo


_ROOT Version:6.18/00
Platform: Windows 10
Compiler: Not Provided


Hi Matteo,

I have seen this error a couple of times. I’ll try to reproduce it and fix it asap.

Cheers, Bertrand.

Hi Bertrand,

thanks! Looking forward to use ROOT again,

Cheers,
Matteo

Note that you can compile your code normally, with the regular cl.exe (from a x86 Native Tools Command Prompt for VS 2019)

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.