Problem setting DISPLAY on Mac OS X 13.0.1 (22A400)

I started having an issue in the graphic display when running ROOT in ssh.
I’m a novice who has just come into contact with Rhopi. When I finish the homework assigned by the teacher, I need to see the image of the root, but I keep reporting an error, such like:
*** DISPLAY not set, setting it to
When I enter the code that opens the total file to see the image:
root [1] TBrowser d
it will appear:
Error in <TGClient::TGClient>: can't open display "", switching to batch mode... In case you run from a remote ssh session, reconnect with ssh -Y
After that, I logged in to the terminal with VScode and installed the Remote X11 plug-in. Unfortunately, it didn’t play any role. It reported the same error as the terminal that came with the computer. This may have something to do with not configure the plug-in myself. But my brother can successfully see the root image by logging in to my account with his Windows computer, which bothers me. I’m a novice who has just started for a week. Since I’m not with the teacher and he doesn’t use an Apple computer, so he can’t help me.Please help me. Thank you very much!

Welcome to the ROOT forum

As said the error message you need to connect with ssh -Y
But also you need to make sure XQuartz is installed on your Mac.

Thank you very much. The link ssh -Y was also an error before I installed XQuartz. After installation, these problems were solved smoothly. I can successfully see the image. Thank you very much! I was the first person in our scientific research team to use Apple computers to work, and other members can’t help me with the problems I encounter. Now it seems that the question I asked is really low-level, haha. Anyway, thank you very much!

1 Like