Problem in converting .hbk file to .root by h2root

Continuing the discussion from Problem in converting the .hbk file to .root by h2root:

Hi @pcanal,

Thank you for your interest. No, the problem is not solved yet. I move on by splitting the jobs which will create smaller files. Please find the link to download the .hbk file which size is large that’s why I am unable to upload here.


ROOT Version: Not Provided
Platform: Not Provided
Compiler: Not Provided

Are you able to open this file in PAW? I am not. This possibly suggests that the file itself is broken (and not “h2root”).

Maybe you could check what “record length” (the parameter often called “LRECL” in “HBOOK” functions, its usual default value is 1024 “words”) was used when creating this file (and if the “QE” option was used).

Assuming that all your files are created in the same way, providing a small file (which works for you) for inspection should be sufficient, too.

You can find some guidance concerning the maximum “HBOOK” file size in the “PAW FAQs” in the “How to create very large ntuples (RWN or CWN) ?” entry. If all parameters are left at their default values then it’s 125 MB (1024 * 32000 * 4 Bytes).


I am not using PAW. Also, “LRECL” filename is not working in terminal.


ping … @brun and @couet

Your file seems corrupted. I have tried to open it with paw without success:

PAW > hi/file 0 exp.hbook
 error in CFSEEK : Invalid argument
 error in CFSEEK : Invalid argument
 error in CFSEEK : Invalid argument
 error in CFSEEK : Invalid argument
 error in CFSEEK : Invalid argument

and when I try to open it with LRECL = 0 to let paw determine the record length I get:

PAW > hi/file 0 exp.hbook 0
 RZOPEN. Cannot determine record length -  EXCHANGE mode is used.
  RZOPEN. Error in the input file
 ***** ERROR in PAWROP : Cannot open file :  
PAW > 

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.