Prevent hashing to dissapear anti-aliasing LaTeX

Dear root experts,

This is a question about LaTeX but for ROOT users that is why I ask this here.

I use hashed histograms and want them to include in a latex file. But when I anti-alias the file the hashing dissapears.

Question: How can I anti-alias the whole document except for the hashsed histograms I have in .eps pictures. The best would be that the TEXT in the histograms is anti-aliased but the hashing does not dissapear.

Many thanks for the solution!!


PS. I use the package “graphicx” in latex…

PPS. When it comes out of the printer all is fine, but in screen …

The problem with anti-aliasing and hatches in well know with “gv”. This is a know “gv” bug. But I am not aware (of forgot) about this one. Can you send the latex command you are using and also a small latex example file showing the problem you encounter ?

Hi, yes, here is a minimal example with all the info you need to know (can be used for reference):

I just tried another ps viewer “GSView” and this one has the option to set an “alpha” parameter for both text and graphics. Here one can choose to set the anti-aliasing (because that is what it is) to 1 for graphics (and then the hashing is nicely present) and to 4 for text so the table (in the example above where the table itself is also included as an .eps file) looks great too!!



I tried your example. There is nothing new compare to what is decribed here:
ie: The hatches do not appear in gv, because by defualt the antiliasing is on. But if you do what is recommended in ht09.html it is ok. Also the file prints correctly.

Hi again, yes, that is correct.

I hadn’t seen that site before of yours.

What is meant with the last line: “The valid patterns are:”? These are the patterns that should re-appear after switching off the anti-aliasing?

Yes, these patterns are visible in gv when the ani-aliasing is turned off (GV bug). The attached macro shows the avaible hatches.
pat.C (1.8 KB)