No such file or directory for all the root headers in scons

Dear all,

I am trying to compile a scons based software repository, where many root headers are included. has been executed, and I also confirmed that the environment variables contain the correct path for root:
However, when I did scons on the code, there are always error messages showing up:

fatal error: TClonesArray.h: No such file or directory
fatal error: TObject.h: No such file or directory

Seems that none of the root headers can be found by scons.
The scons script itself should be no problem as it has been tested with other PC.
Could anyone please share their experience and possible workaround on it?
Thank you in advance.

ROOT Version: 6.28.04 and 6.20.00
Platform: Rocky Linux 9
Compiler: scons

I am not sure what could be wrong but there is a few topics in this forum about “scons”. Have you seen them ?

Yes, I checked some of them and they seem to be like a problem of missing path definition. With a different test using Makefile, it confirms my paths are defined.

According to this page SCons is an Open Source software construction tool. Think of SCons as an improved, cross-platform substitute for the classic Make utility with integrated functionality similar to autoconf/automake and compiler caches such as ccache. In short, SCons is an easier, more reliable and faster way to build software.
I understand your have an other software using ROOT having its installation managed with scons. I guess you primarily installed ROOT ? was this installation correct ? can you run ROOT ?

Yes, I can run root with the newest version, which was built locally using the binary version.
I re-checked the scons script and source code package, and tried with newer version of the repository, and scons worked. It seems that the version of software repository is not supported by my OS version, so not a problem of root.
Thank you for the help.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.