No graphics (TCanvas, TBrowser etc ) opens with root 6.20/02 on Ubuntu 18.04


I had my system recently updated to ubuntu 18.04 from 14.04 (with root 6.06). Since root needed to be reinstalled I decided to pass to the most recent version. I made the installation according to the instructions, using cmake. I didn’t notice any warning or error during the compilation.

Starting root, the logo picture does not appear (not sure if this isn’t part of the new version), my old scripts run and compile without problem, but no graphics appear and I recieve a lot of warning or error messages about everything that to do with Draw or Fit.

Trying a simple thing, just opening a TCanvas, I get the following message:

root [0] new TCanvas("c1","cccccc")
Warning in <TCanvas::ResizePad>: c1 width changed from 0 to 10

Warning in <TCanvas::ResizePad>: c1 height changed from 0 to 10

(TCanvas *) 0x561d671fe9a0

No canvas opens! Similarly, trying new TBrowser, nothing comes out.

I have checked similar reports in the forum, but none seems to fit with my case.
I have also tried to use the pre-built version [root_v6.20.02.Linux-ubuntu18-x86_64-gcc7.5.tar.gz] and I got exactly the same idea.

Any suggestion please?

Thank you very much in advance!


ROOT Version: 6.20/02
Platform: Ubuntu 18.04
Compiler: gcc 7.5.0

clang version: 5.0.0

It looks ok on my Mac with 6.20/03:

root [0] new TCanvas("c1","cccccc")
(TCanvas *) 0x7fb5474d4f50
root [1] 

I do not see why Ubuntu should special for a such simple thing ?
Nothing should have changed in that area… TBrowser is the same ?
Are you working remotely on that machine ?

Yes I work remotely on this machine. But used to be ok in the past. Plus, I can open windows as terminals, editors browsers etc.

For TBrowser I don’t get an error message but it does not appear

You do ssh -X -Y ?

Yes. As I mentioned I can open terminals, editors browsers etc. And the root scripts compile and run with no errors or warnings. But no canvas or other graphic oblect appears.

Make sure that nothing in your environment points to your old ROOT version. Check “ROOTSYS”, “PATH” and “LD_LIBRARY_PATH”. Check that you do not have any old “rootlogon.C” nor “.rootrc” files. Try to run “root -n”. Make sure that the directory “root-config --etcdir” exists and that it contains files belonging to your new ROOT version.

That was it! Removing the .rootrc solved the problem!!!

Thank you very much for your help!!!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.