macOS Sonoma - root 6.28.06: TBrowser window freezes upon opening when not in web mode

I recently upgraded to macOS Sonoma. After recompiling root I run into a curious problem. If I run root with the web interface on, everything is fine. If I run with the option --web=off, I am unable to open a TBrowser (see attached image).

I can successfully open a graphical canvas with, for instance:
TF1 f1(“f1”,“sin(x)/x”,0.,10.); f1.Draw()
Then everything freezes if I run
TBrowser t
After closing the failed TBrowser window I get back the control of the first canvas.
After quitting root I get the following messages:
root.exe[33530:2781385] Fatal error: requested non-existing drawable 204
root.exe[33530:2781385] This window not found among allocated/deleted drawables

I would be grateful if anybody can point me towards a possible solution (maybe some configure options prior to compilation?).

_ROOT Version:_6.28/06
_Compiler:_Apple clang version 15.0.0 (clang-1500.0.40.1)

This has been fixed in master with: Fix Cocoa GUI for MacOS14 and Clang15 by couet · Pull Request #13885 · root-project/root · GitHub
And back-ported in 6.28 with: [v6-28] Backport Cocoa by couet · Pull Request #14020 · root-project/root · GitHub

Dear Olivier,
Thanks for this!
I never dealt with root patches. If I understand correctly, I just need to get the latest stable release and implement the changes (just few lines) to the files
as specified in the backport link.

Thanks again,

Yes, that means you start from sources ?

Dear Oliver,
I just compiled from sources with the patch and the problem is completely resolved.

After a new macOS installation I usually install root with homebrew (and let it install whatever python3 it requires) - this is very fast.
Alternatively, if I need a newer version of python3 or if I need to modify the code (as in this case) I compile from sources.
Is there a better way?


1 Like

Great !

No that’s the right way.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.