Libpng conflict


I’m running root 5.30.02 (just installed the newest version). When calling TCanvas::Print() with a png output I get the following message:
libpng warning: Application built with libpng-1.2.44 but running with 1.5.4
and the output files are empty. I’m unsure why a build with 1.2.44 but running with a newer version should cause a conflict - is there an easy solution?


On which platform are you running ?

Of course the more direct way to make it work would be to recompile root on your machine.

The message said that root was build with a given version of libpng for the platform you are working on,
and on your actual machine you have a more recent version which is not compatible with the version ROOT was build against.

I’m running OS10.7. I downloaded an install from binaries version of root5.30 but then compiled it with a package manager that is distributed with the experiment I work on. I guess that’s were the conflict is…

I try confuguring and remaking root away from outside the package manager, but get the same error messages when printing to png format. Is there a configure option to tell root where to search for libpng when compiling? I have ONLY have libpng15 installed in the directory that the makefile should be looking in, libpng and png.h are both symbolic links to png1.5, but even when I edit the configure file to look for libpng15 I get the same error.

Simple fix : update to root5.30.03!