Please read tips for efficient and successful posting and posting code

ROOT Version: 6.28/02
Platform: WSL Oracle Linux Server 9.2
Compiler: yum


I have installed root on WSL using
sudo yum install root

I can now use when running python:
import ROOT

When I’m trying to import ROOT from a jupyter notebook it says:
ModuleNotFoundError: No module named 'JupyROOT'

I tried naively:
sudo yum install root-notebook

But using import ROOT from this server does not work as well.

What should I do? I hope not to need to compile root from source.
Thank you.

Maybe @vpadulan has an idea about it?

Hi @Dor_Miron ,

I am a bit surprised that you can use yum on WSL. By default, you should get a ubuntu image. And we don’t have ROOT packages on the official ubuntu repositories.

But, since you are using yum, I will suppose that you are using some kind of RHEL distribution. On AlmaLinux 9 for example, the following gives me a working environment with ROOT being usable from the Python prompt or jupyter

$: yum install epel-release
$: yum update
$: yum install root python3 python3-root python3-pip
$: pip install jupyter


1 Like

Hi vpadulan, thank you for your answer.

The WSL I have installed is an “WSL Oracle Linux Server 9.2” quoting from
cat /etc/os-release
Which uses the yum package manager.
I have installed this image exactly because it is more easily supported than Ubuntu (please tell me if you think otherwise)

Anyway, I have tried to run the commands you offered and other than some packages installed by
yum update
Nothing had changed. I also tried once again to import ROOT from a notebook and got the same error.

Thank you,

Any suggestion on how can I solve this issue?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.