Issue with ROOT graphics

ROOT Version: 6.26/10
Platform: Ubuntu 22.04.2 LTS installed as VM on Windows 10 Host (VirtualBox 7.0.6)

Since this morning (updated to VirtualBox 7.0-6) I’m having an issue in starting whatever ROOT UI.
No error message is printed out, however, when I open e.g. a TBrowser, it appears very broken (see below).

I installed the new VBox Guest Additions, but nothing really changed.
I also recompiled ROOT with no improvement
Do you have any suggestions?

Welcome to the ROOT forum

Yes, that’s weird. May be @bellenot has an idea.

Thank you @couet !
A quick update, I tried creating another VM with the same Ubuntu and ROOT version and the problem didn’t occur.
I also noticed that a similar artifact happens with glxgears (see below)


I’m not an expert in this graphics libraries, do you have suggestions on things that I should check/re-install? (xorg, GL libraries, etc.?)
Also, I don’t know if this information is of any use, but I have an intel graphics processor (no discrete GPU)

Th wrong image you posted firt is the GUI, that’s not graphics. @bellenot is our GUI expert.

My bad! Apologies!

No idea what could be the issue, but if that happened right after the update of your Virtual Machine and if it works with another VM, then I would blame the VM itself…

I kept digging and found out that the issue was caused by the 3D acceleration option in VirtualBox. As of now, I haven’t found a way to get it to work again, but unticking that option solved all my issues.



This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.