Is the gas file inappropriate?

When running the program, the terminal displays the following statement:

Rate at 213.998 eV is not included in the current table.
Increasing energy range to 224.698 eV.
AvalancheMicroscopic::TransportElectron: Increasing null-collision rate by 5%.

Is this because the electron energy is too high? Is the gas file data inappropriate? How to solve this problem?

I simulate photons at 5.9keV.

I guess @hschindl can help.

It’s not necessary a problem. MediumMagboltz doesn’t know anything about the electric field in which the electrons will drift (and hence their energies), so it makes a default guess for the electron energy range. If an electron exceeds this range, the upper limit is increased and the cross-section table is reloaded. You can suppress/avoid this by setting the energy explicitly upfront (SetMaxElectronEnergy).

Thank you.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.