Installing ROOT on Windows 10 OS

Please read tips for efficient and successful posting and posting code

_ROOT Version: ROOT 6.24
_Platform: Windows 10
_Compiler: Visual Studio 2019

Dear ROOT community,

I’m trying to install ROOT on my Windows 10 OS, but I ran into this problem when starting a ROOT session:

input_line_1:1:10: fatal error: 'new' file not found
#include <new>
Replaced symbol atexit cannot be found in JIT!
Replaced symbol at_quick_exit cannot be found in JIT!
Replaced symbol __dllonexit cannot be found in JIT!
Replaced symbol _onexit cannot be found in JIT!
input_line_3:37:10: fatal error: 'string' file not found
#include <string>
  | Welcome to ROOT 6.24/02               |
  | (c) 1995-2021, The ROOT Team; conception: R. Brun, F. Rademakers |
  | Built for win32 on Jun 28 2021, 09:28:51                         |
  | From tags/v6-24-02@v6-24-02                                      |
  | With MSVC 19.23.28107.0                                          |
  | Try '.help', '.demo', '.license', '.credits', '.quit'/'.q'       |

input_line_7:1:10: fatal error: 'iostream' file not found
#include <iostream>

Can you help me solve this?

Thank you.

Try installing this way:

I tried doing this, but when I reinstalled ROOT, I got an error message of “Warning: PATH too long installer unable to modify PATH!”. I added root/bin to the PATH variable manually, but with no luck. I’ve also tried setting the registry key LongPathsEnabled to 1, but that didn’t help either.

Any suggestions?

What path did you use? Anyway, I’ve never seen that warning, so I don’t know what it really means; maybe the bin path is too long, or your path variable is already too long (too many/long entries), etc… look for that message in google! But why don’t you try with a shorter path? Also, if you have too many or too long entries in your path, keep in mind that there are paths for “all users” and for the “current user”, so you could try adding root to either and see which one works. In all cases, I also suggest to avoid spaces and special characters or symbols in folder and file names; just keep everything as simple as possible.

It’s because your PATH contains too many characters (nothing to do with ROOT)