Installing Root on ubuntu 14.04

Good morning,

When launching the following ./configure command:

I have the following message:

[quote]Checking for source directory … /usr/physics/root_v5.34.32
Configuring for linuxx8664gcc
INFO: --enable-asimage: already enabled by default.
INFO: --enable-astiff: already enabled by default.
INFO: --enable-builtin-afterimage: already enabled by default.
WARNING: option --enable- is deprecated and ignored!
Invalid option ‘–enable-’. Try ./configure --help

I work with Ubuntu 14.04 and gcc version 4.8.4. What option should I use in place of --enable- ?

Many thanks,

Best regards,


Hi Thomas,

You have typos in your options. Try: ./configure linuxx8664gcc --enable-asimage --enable-astiff --enable-builtin-afterimage --enable-builtin_ftgl --enable-builtin_glew --enable-builtin_pcre --enable-builtin-lzma --enable-cintex --enable-explicitlink --enable-fftw3 --enable-genvector --enable-krb5 --enable-mathmore --enable-memstat --enable-mysql --enable-opengl --enable-pgsql --enable-pythia6 --enable-python --enable-reflex --enable-roofit --enable-shadowpw --enable-shared --enable-ssl --enable-tmva --enable-vdt --enable-x11 --enable-xft --enable-xmlAnd don’t use sudo.

Cheers, Bertrand.

Try ([url= sure you start with a “fresh” source code[/url]):

unset ROOTSYS ./configure --enable-soversion --all > configure.out.txt 2>&1 make > make.out.txt 2>&1 and if you have “libpythia8-dev” package installed, add “–with-pythia8-incdir=/usr/include/Pythia8” to the configure line above (you can also add “–build=debug” if you like).

P.S. Note that you must first get rid of the “system-provided” ROOT version, if installed. Execute “sudo apt-get purge root-system* root-plugin* libroot*” (afterwards check that the “/usr/lib/i386-linux-gnu/root5.34” and the “/usr/lib/x86_64-linux-gnu/root5.34” subdirectories disappeared completely).

I launch the ./configure command and then launch the compilation with make. ROOT is successfully built.

However when launching root, it gives:

[quote]Couldn’t find font “-adobe-helvetica-medium-r---10-----*-iso8859-1”,
trying “fixed”. Please fix your system so helvetica can be found,
this font typically is in the rpm (or pkg equivalent) package
XFree86-[75,100]dpi-fonts or fonts-xorg-[75,100]dpi.

  •                                     *
  •    W E L C O M E  to  R O O T       *
  •                                     *
  • Version 5.34/32 23 June 2015 *
  •                                     *
  • You are welcome to visit our Web site *
  •      [](            *
  •                                     *

ROOT 5.34/32 (v5-34-32@v5-34-32, Jun 23 2015, 17:58:02 on linuxx8664gcc)

CINT/ROOT C/C++ Interpreter version 5.18.00, July 2, 2010
Type ? for help. Commands must be C++ statements.
Enclose multiple statements between { }.
root [0] [/quote]

After some researchThis is due to a previous package xfs which does not exist in Ubuntu 14.04. I found some more information here:

and here:
[url]Adobe helvetica on ubuntu 11.04

It looks like ROOT continues running without any problem.

If you have some other suggestion to correct the bug described above, do not hesitate to post it.

Many thanks,


Hi Thomas,

Use ROOT 6, where this issue has been fixed… :wink:

Cheers, Bertrand.

I DO NOT get this warning on my Ubuntu 14.04 where I DO NOT use “xfs”.
You just need to install appropriate fonts (maybe the “gsfonts-x11” and/or “xfonts-base” and/or “xfonts-scalable” and/or “xfonts-100dpi” and/or “xfonts-75dpi” packages).
Then, for “better appearance”, edit the “${ROOTSYS}/etc/system.rootrc” file and set “X11.UseXft:” to “yes” (by default it is “no”).

Good morning,

many thanks, I will try your suggestion. However I discovered another problem when executing:

I have:

and when typing

it gives:

[quote]/usr/physics/root_v5.34.32 /usr/physics/root_v5.34.32

/usr/physics/root_v5.34.32 is the directory where all ROOT files are installed on my machine whic is in tcshrc mode.

Since the bin/thisroot.csh is generated after the compilation, is it possible to remove it and then launch again the compilation to solve this problem ? Otherwise, what can I do to solve this bug ?

Thanks a lot.


I don’t get this error.
Assuming that you are using [t]csh, try:
source /usr/physics/root_v5.34.32/bin/thisroot.csh
or if you’re using [b][ak]sh, try:
. /usr/physics/root_v5.34.32/bin/


I have the same error by executing this command …

How can I purge the installation ?

I executed:

then I checked that both /usr/lib/i386-linux-gnu/root5.34 and /usr/lib/x86_64-linux-gnu/root5.34 are not present.

However when I need to use sudo when launchin the ./config command since the generated files can not be written on the /usr/physics/root_v5.34.32 directory


I do

make clean

and remove the /usr/physics/root_v5.34.32/bin directory.

Then I start the compilation at the beginning. However I need to use sudo
to execute ./configure, otherwise I have not the permission to create the
needed output file.

Then I relaunch

The compilation went well but when executing thisroot.csh I have the same
bug in the ROOTSYS variable definition as described in my former post.

Otherwise I can run ROOT but if ROOTSYS is not correctly defined it is not satisfying.

I have not so much idea right now, so does somebody has a suggestion ?


As I just replied by mail:
I don’t understand why you need sudo. Could you build ROOT where you have write permission? Otherwise you force people to be sudo in order to do anything with ROOT, and I’m not even sure if it will work at all…

And please don’t post the same question to different places

Cheers, Bertrand.

Hello Bertrand,

I am sorry so I am staying in the forum for the following. I am not new to Linux and have been using ROOT for many years but it is the first time I install ROOT on my own.

I wanted to install ROOT in the /usr since I am on a laptop where I have administrator rights.
I just want to install the executable in the /usr/ because it looks the more convenient. Using ROOT and producing histograms etc … is performed from my home directory and included subdirectories.

I repeated the command you gave me and it gave the same wrong definition i.e:

Then as output:


/usr/physics/root_v5.34.32 /usr/physics/root_v5.34.32

Do you have any idea what could be wrong ?

Many thanks


Hi Thomas,

OK, so what is your shell? bash? [t]csh?
Could you try:. /usr/physics/root/bin/
Cheers, Bertrand.

My machine is in tcsh mode

When executing your command:

I have:

i.e Permission denied

By adding sudo in front of the command:

This command you give me is for bash mode, isn’ it ?

Yes. So the correct one issource /usr/physics/root/bin/thisroot.csh
But it looks like ROOTSYS has twice the value (/usr/physics/root_v5.34.32 /usr/physics/root_v5.34.32). What gives echo $ROOTSYS in a fresh console, without sourcing the thisroot.csh script? And try to unset $ROOTSYS before to source the script?

Try in [t]csh (build it in “/tmp/ROOT/root”, install it into “/usr/physics/root_v5.34.32”) … cd /tmp sudo rm -rf ROOT mkdir ROOT cd ROOT wget tar -zxf root_v5.34.32.source.tar.gz cd root setenv ROOTSYS /usr/physics/root_v5.34.32 sudo rm -rf ${ROOTSYS} ./configure --enable-soversion --all make sudo ROOTSYS=${ROOTSYS} make install cd /tmp rm -rf ROOT If you have “libpythia8-dev” package installed, add “–with-pythia8-incdir=/usr/include/Pythia8” to the configure line above (you can also add “–build=debug” if you like).
Then in [t]csh … cd source /usr/physics/root_v5.34.32/bin/thisroot.csh root

Dear Bertrand and Will E Coyote,

I found out where the problem was. In my .tcshrc, I defined an alias following:

(which is inappropriate).

When having a look at the usr/physics/root/bin/thisroot.csh macro, this alias creates a repetition with the following line of the shell macro:

Now I remove the alias from the .tcshrc, and the command
source /usr/physics/root_v5.34.32/bin/thisroot.[c]sh

works properly. Now:

echo $ROOTSYS gives:


echo $PATH gives

echo $LD_LIBRARY_PATH gives:

I ran successfully the tutorials macros hsimple.C and h1draw.C

I will try Will E Coyote suggestions to solve the font bug.

Many thanks to both of you !