Installing ROOT 6.26 on macOS 12.2.1

_ROOT Version:6.26.00
_Platform:macOS 12.2.1
_Compiler: using Xcode 13.1

I am unable to install the binaries from
root cern releases release-62600

I’m unable to unpack the package as I get a message that the file is from an “unidentified developer”. There doesn’t seem to be a possibility to override this on macOS 12.2 but it may also be due to security software or settings my university has installed on my laptop – or perhaps a build failure?

I have tried with both Xcode 13 and 13.1.

I have also tried to build from source. I used macPort for this and it failed in compiling xRootd.

Using the compliers downloaded from macPorts I can build using the instructions given on the web page listed below (I’m not allowed to post links but you get the idea.)

root cern install build_from_source

This fails on “Performing the configure step” (17%) for Xrootd v5.4.1

I get a similar failure in Xrootd if I try to directly install root6 with macPorts.

Any suggestions would be most welcome.

Best wishes,
David Strom


I was able to get a successful build after doing the following – this may be of use to others who are prevented from using the prebuilt binaries as I was.

These instructions are for macOS 12.2.1

  1. Install Xcode 13.1 from the apple web site (I’m not allowed to post links I believe)
  2. Install command line tools 13.1 from the apple web site.
  3. Fire up Xcode and register accept the apple agreement
  4. Install macports and then

sudo port install root6

  1. This will fail when loading xrootd, but it will install all of the tools needed to build root

  2. Download root_v6.26.00.source.tar.gz and unpack (tar -xf v6.26.00.source.tar.gz )

  3. Follow the instruction to build from the root web site and but using the following configure command

cmake -Dxrootd=OFF -Druntime_cxxmodules=OFF -DCMAKE_INSTALL_PREFIX=<install_dir>

cmake --build . --target install

I would appreciate feedback on the “unidentified developer” issue – is this just me or do others have this problem.

Best wishes,
David Strom

@couet any idea of what “unidentified developer” message is when using the binaries for mac?

I am not sure what does that mean. I never saw that. May be @axel has an idea. That can be some kind of licensing stuff I am not aware about…

You need to download the package with curl -L -O or else macOS goes nuts about untrustworthy people. At some point we will sign and notarize the binaries - but that’s not happening yet.

Thanks very much Axel. I can confirm that I was able to download and open this with curl rather than using the browser.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.